Problemas para instalar Ruby a traves de RVM en un servidor Debian


#1

Buenos dias…

En estos dias he estado configurando un servidor para fines diversos
dentro de mi trabajo y he presentado problemas a la hora de instalar
Ruby a traves de RVM. Ya he instalado todas las dependencias y el
problema persiste y no se cual podria ser la solución.

  • Al ejecutar # rvm install ruby, se ejecuta hasta la pantalla mostrada
    en
    Captura1.JPG
    "No binary rubies available for: downloads/ruby-1.9.3-p362.
    Continuing with compilation. Please read ‘rvm mount’ to get more
    information on binary rubies.
    Installing Ruby from source to:
    /home/adminweb/.rvm/rubies/ruby-1.9.3-p362, this may take a while
    depending on your cpu(s)…
    ruby-1.9.3-p362 - #downloading ruby-1.9.3-p362, this may take a while
    depending on your connection…
    ruby-1.9.3-p362 - #extracted to /home/adminweb/.rvm/src/ruby-1.9.3-p362
    (already extracted)
    Patch segfault_fix_7629 was already applied.
    ruby-1.9.3-p362 - #configuring

"

  • Al matar el proceso aparece el mensaje mostrado en Captura2.JPG
    “Error running ‘./configure --enable-shared --disable-install-doc
    –prefix=/home/adminweb/.rvm/rubies/ruby-1.9.3-p362
    –with-opt-dir=/home/adminweb/.rvm/usr’, please read
    /home/adminweb/.rvm/log/ruby-1.9.3-p362/configure.log
    There has been an error while running configure. Halting the
    installation.”

  • Captura3.JPG muestra donde se detiene la instalación ejecutando el
    comando # rvm --trace install ruby
    "++ /scripts/functions/utility : __rvm_log_command() 116 > ./configure
    –enable-shared --disable-install-doc
    –prefix=/home/adminweb/.rvm/rubies/ruby-1.9.3-p362
    –with-opt-dir=/home/adminweb/.rvm/usr
    "

Muchas gracias por su ayuda…