Problemas con rake db:migrate

Hola.

Estoy empezando con esro de RoR y al intentar ejecutar rake db:migrate
siempre me da un error:
rake aborted!
#28000Access denied for user ‘root’@‘localhost’ (using password: NO)

¿A que puede ser debido?.

Gracias por adelantado.

Un saludo

Has configurado la base de datos? config/database.yml. Yo
normalmente recomiendo empezar con SQLite3 para evitar este tipo de
engorros.

Un saludo,

Francesc

On Nov 14, 2007, at 6:35 PM, Greg N. wrote:

Un saludo

Posted via http://www.ruby-forum.com/.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí
voice. +34 678.681.603

Francesc E. wrote:

Has configurado la base de datos? config/database.yml. Yo
normalmente recomiendo empezar con SQLite3 para evitar este tipo de
engorros.

Un saludo,

Francesc

On Nov 14, 2007, at 6:35 PM, Greg N. wrote:

Un saludo

Posted via http://www.ruby-forum.com/.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí Švoice. +34 678.681.603

Si, tengo configurado el fichero database.yml.
Lo curioso es que he estado haciendo cosas con la base de datos en dias
anteriores y todo ha ido bien y de buenas a primeras (eso creo yo aunque
seguro que no es así) es cuando me ha empezado a dar problemas.
He desinstalado mysql server y vuelto a instalar y configurar y sigue
igual.
Hay algo que hice algun tiempo y que fue avctualizar gems y no se si por
ahi pueden ir los tiros.

Gracias por la ayuda.

si se os ocurre cualquier otra cosa os agradecería mucho que me lo
dijerais.

Saludos.

On Nov 14, 2007 4:57 PM, Greg N. [email protected]
wrote:

Si, tengo configurado el fichero database.yml.
Lo curioso es que he estado haciendo cosas con la base de datos en dias
anteriores y todo ha ido bien y de buenas a primeras (eso creo yo aunque
seguro que no es así) es cuando me ha empezado a dar problemas.
He desinstalado mysql server y vuelto a instalar y configurar y sigue
igual.
Hay algo que hice algun tiempo y que fue avctualizar gems y no se si por
ahi pueden ir los tiros.

$ rake db:migrate RAILS_ENV=production

o el que quieras?

  • La base de datos está creada?
  • El usuario tiene acceso a esa db?
  • Las migraciones estan bien escritas?

Haz un rake db:migrate --trace y manda la salida a la lista.

Un saludo,

Francesc

On Nov 14, 2007, at 8:57 PM, Greg N. wrote:

name. Francesc E. i Martí Švoice. +34 678.681.603
Hay algo que hice algun tiempo y que fue avctualizar gems y no se si
Posted via http://www.ruby-forum.com/.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí
voice. +34 678.681.603

$ rake db:migrate RAILS_ENV=production --trace

A ver el output de eso …

Francesc

On Nov 14, 2007, at 9:05 PM, Damian J. wrote:

Hay algo que hice algun tiempo y que fue avctualizar gems y no se
si por
ahi pueden ir los tiros.

$ rake db:migrate RAILS_ENV=production

o el que quieras?


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí
voice. +34 678.681.603