Problemas con librerias RMagick

Hola a todos.

Veamos, estoy usando el plugin FileColum
(rails/vendor/plugin/trunk) y queria implementar la opcion size o
geometry de RMagick.
cuando n el modelo pongo:
class Usuario < ActiveRecord::Base
file_column :image
…resto del codigo…
end

Funciona bien, sube las imagenes y todo eso. Pero si pongo

class Usuario < ActiveRecord::Base
file_column :image, :magick => { :geometry => “640x480>” }
…resto del codigo…
end

Me da este error:

/usr/lib/ruby/gems/1.8/gems/rmagick-1.15.4/lib/RMagick.so: cannot open
shared object file: No such file or directory -
/usr/lib/ruby/gems/1.8/gems/rmagick-1.15.4/lib/RMagick.so
RAILS_ROOT: …/config/…

This error occurred while loading the following files:
RMagick
RMagick.so

He intentado añadiendo require ‘RMagick’ a los modelos, pero sigue sin
funcionar
los ficheros /usr/lib/ruby/gems/1.8/gems/rmagick-1.15.4/lib/RMagick.so y
RMagick existen.
El caso es que en el servidor no me dejan cambiar el ld.so.conf ni
tampoco crear la variable de entorno LD_…_PATH = /usr/lib

Sabéis alguna forma de que la aplicación cargue esos dos ficheros
RMagick.so y RMagick desde alguna carpeta diferente…por ejemplo
rails/libreria, cambiando el environment o algo asi (sin que tenga que
tocar nada del directorio del servidor? O como solucionar el problema?
Gracias!

Some ideas about this problem? thanks!
Reply With Quote

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs