Problemas con instalación de gemas

Buenas lista,

desde unos días estoy experimentando algunos problemas con la
instalación de gemas en Mac Os X.
El problema básicamente es que despues de instalar una gema que contenga
un archivo ejecutable, por ejemplo ZenTest tiene autotest, no me los
instala en la ruta bin para que estean accesibles. Si accedo a la ruta
bin donde está la gema /opt/local/lib/ruby/gems/1.8/[[nombregema]]/bin
si que puedo ejecutarlo.

Ya digo que antes me iba perfectamente.

Tengo una instalación de ruby y rubygems desde las fuentes.
lo que me saca el gem environment es:

RubyGems Environment:

  • RUBYGEMS VERSION: 1.1.1
  • RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111) [i686-darwin9.2.2]
  • INSTALLATION DIRECTORY: /opt/local//lib/ruby/gems/1.8
  • RUBY EXECUTABLE: /opt/local//bin/ruby
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86-darwin-9
  • GEM PATHS:
    • /opt/local//lib/ruby/gems/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
    • :sources => [“http://gems.rubyforge.org”]
  • REMOTE SOURCES:

y esto el contenido de la variable PATH
/Library/PostgreSQL8/bin:/opt/local/mysql/bin:/opt/local/nginx/sbin:/opt/local/apache2/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

que puede ser??

Gracias antes de nada


Paco Dieguez
Linux User #409880
Chave GPG: A2A4F9B8 en keyserver.rediris.com
www.mabishu.com

/opt/local/lib/

Te lo has instalado con Mac Ports o algo parecido?

2008/5/9 Fran Dieguez (GLUG) [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs