Problemas con gemas

Buenos dias a todos.

Resulta que estoy con un proyecto en el que hasta ahora no habia
necesitado instalar nuevas gemas. Hace unos dias estuve leyendo a cerca
de varias gemas interesantes como will_paginate, spreadsheet y alguna
mas. Decidi entonces instalarlas con “gem install ‘nombre de la gema’” y
me decia que me la habia instalado satisfactoriamente.
Pero cuando he intentado introducir codigo bastante sencillo como el
siguiente:

@products = Product.find(:all).paginate…

me dice que paginate no es un metodo.
Al igual me paso con Spreadsheet, Parseexcel, Paginate 1.0…

No creo que sea error de codigo, si no algun error a la hora de instalar
las gemas, o que me falta algun require en alguno de los archivos de la
carpeta config.

¿ayuda?

Muchas gracias

Por cierto utilizo las versiones:
Rails 3.0.3
Ruby 1.92
Y estoy trabajando bajo windows vista

RESUELTO!

El problema era que yo instalaba las gemas mediante el comando “gem
install…” y rails no encontraba por ningun lado las gemas.

Despues de mucho mirar y probar, decidi instalar las gemas mediante el
comando “bundle install”.
Primero abres el Gemfile de tu proyecto y escribes al final del archivo
“gem ‘will_paginate’,‘2.3.15’” por ejemplo. Luego ejecutas bundle
install mediante la consola.

Asi se consigue que Rails utilice las gemas que instalas.

Saludos

Buenas tardes

Estoy intentando montar un proyecto de Ruby on Rails con Mongoid que
funciona perfectamente en un equipo con Ubuntu y tengo problemas para
ejecutar el bundle install porque al intentar instalar sale el siguiente
problema:

delayed_job_mongoid (= 1.0.2) depends on
mongoid (~> 2.0.0.rc)

mongoid (2.0.0.beta.17)

mi Gemfile está de la siguiente manera

gem ‘rails’, ‘3.0.3’
gem ‘mongo’, ‘1.0.7’
gem ‘mongoid’, ‘2.0.0.beta.17’
gem ‘bson_ext’, ‘1.0.4’
gem ‘devise’, ‘1.1.5’
gem ‘warden’, ‘1.0.3’
gem ‘heroku’, ‘1.9.11’
gem ‘typhoeus’, ‘0.2.1’
gem ‘koala’, ‘0.10.0’
gem ‘haml’, ‘3.0.25’
gem ‘compass’, ‘0.10.6’
gem ‘fancy-buttons’, ‘1.0.6’
gem ‘rb-inotify’, ‘0.8.4’
gem ‘carrierwave’, ‘0.5.1’
gem ‘aws’, ‘2.4.2’
gem ‘fastercsv’, ‘1.5.4’
gem ‘nokogiri’, ‘1.4.4’
gem ‘prawn’, ‘0.8.4’
gem ‘dynamic_form’, ‘1.1.3’
gem ‘activemerchant’, ‘1.10.0’
gem ‘geoip’, ‘1.0.0’
gem ‘uuidtools’, ‘2.1.2’
gem ‘mail’, ‘2.2.15’
gem ‘delayed_job’, ‘2.1.3’
gem ‘delayed_job_mongoid’,‘1.0.2’

gem ‘youtube-g’, :require => “youtube_g”
gem ‘carrierwave-rails3’, :require => ‘carrierwave’
gem ‘mini_magick’, :git => ‘git://github.com/cleon/mini_magick.git’

group :production do
gem “memcache-client”
gem ‘memcached-northscale’, :require => ‘memcached’
end

group :development do
gem ‘mongrel’
gem ‘rails3-generators’
gem ‘ruby-debug’
end


Instalé las gemas delayed_job con sus versiones por aparte pero no se
ven al ejecutar el comando
rake jobs:work

Si alguien conoce de este tipo de error se lo agradezco infinitamente
para evitar instalar una máquina virtual con Ubuntu

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs