Problemas con el plugin FileColumn

Acabo de instalar FileColumn después de leer maravillas de este plugin,
lo he hecho con el siguiente comando
ruby script/plugin install
http://opensvn.csie.org/rails_file_column/plugins/file_column/trunk
y parece que lo ha hecho sin problemas.
El problema es que ahora WEBrick no arranca, aparece el mensaje
=> Booting WEBrick…
y vuelve a la linea de comandos.

Alguna idea?, gracias

En algún tutorial (no recuerdo cual) me decía que tenia que poner las
siguientes lineas en el environment.rb:
require ‘file_column’
require ‘file_column_helper’
require ‘rails_file_column’

Con esto no funciona, me pasa lo que os he explicado antes. Si quito
estas lineas si arranca el WEBRICK.
Al final he optado por el método clasico de instalación, he bajado el
tar.gz y lo he descomprimido en vendor/plugins/file_colum y he añadido
un require ‘file_colum’ en el controlador que lo va a usar. Ahora el
error que tengo es el siguiente:

undefined method `file_column’ for Admin::ObraController:Class

Supongo que no está encontrando el plugin por algún motivo. Se os ocurre
que puede pasar?

Gracias

On Sep 27, 2006, at 9:52 AM, emili wrote:

Acabo de instalar FileColumn después de leer maravillas de este
plugin,
lo he hecho con el siguiente comando
ruby script/plugin install
http://opensvn.csie.org/rails_file_column/plugins/file_column/trunk
y parece que lo ha hecho sin problemas.
El problema es que ahora WEBrick no arranca, aparece el mensaje
=> Booting WEBrick…
y vuelve a la linea de comandos.

Hay algo en el log? Tienes instalado RMagick?

– fxn

P.D.: Como se ha comentado en la lista alguna vez, file_column esta
siendo reemplazado por acts_as_attachment.

OK, voy a probar entonces acts_as_attachment a ver que tal.

Gracias

Xavier N. wrote:

On Sep 27, 2006, at 9:52 AM, emili wrote:

Acabo de instalar FileColumn despu�s de leer maravillas de este
plugin,
lo he hecho con el siguiente comando
ruby script/plugin install
http://opensvn.csie.org/rails_file_column/plugins/file_column/trunk
y parece que lo ha hecho sin problemas.
El problema es que ahora WEBrick no arranca, aparece el mensaje
=> Booting WEBrick…
y vuelve a la linea de comandos.

Hay algo en el log? Tienes instalado RMagick?

– fxn

P.D.: Como se ha comentado en la lista alguna vez, file_column esta
siendo reemplazado por acts_as_attachment.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs