Problema instalando plugins en dreamhost

hola , he tenido algunos problemas instalando plugins en mis proyectos
Rails
que subo a Dreamhost

por ejemplo trato de intalar este :

./script/plugin install
http://todo-list-rails-plugin.googlecode.com/svn/trunk/todo_list/
y recibo este error

./script/…/config/boot.rb:18:in require': no such file to load -- rubygems (LoadError) from ./script/../config/boot.rb:18 from ./script/plugin:2:inrequire’
from ./script/plugin:2

pero en local anda todo bien…

llevo poco tiempo con rails asi que solo puedo intuir que se trata de la
linea 18 de mi archivo boot.rb

la linea 18 de mi archibo boot es:

require ‘rubygems’

asi que supongo que el problema debe estar en la rubygems.

Si alguien puede darme alguna informacion al respecto agradeceré la
ayuda

saludos

On Sep 8, 2007, at 7:29 AM, Miguel M. wrote:

rubygems (LoadError)
la linea 18 de mi archibo boot es:

require ‘rubygems’

asi que supongo que el problema debe estar en la rubygems.

Si alguien puede darme alguna informacion al respecto agradeceré la
ayuda

Rubygems es la libreria que hace de gestor de librerias, es lo que
hay detras del comando gem. El mensaje de error indica que la
libreria rubygems no esta instalada. En primer lugar, tienes en
Dreamhost un hosting que incluye Rails? Has llegado a arrancar la
aplicacion en Dreamhost?

– fxn

P.D.: Un plugin se puede instalar en local y subirlo por svn, pero
hay que rascar en lo de rubygems porque la causa esta ahi y
seguramente tendra otras implicaciones.

Por si te sirve, http://wiki.dreamhost.com/RubyGems

Saludos.

Hola, gracias a los dos por responder.

En efecto , tengo m aplicacion corriendo en dreamhost.

mi problema son dos, uno , al utilizar el plugin file_column para subir
archivos, me arroja un error de que Rmagick no existe. (este plugin lo
subi
a mano por ftp)

el segundo es al utilizar el active_scaffold, que aun no puedo instalar
porque desde ssh no me deja y me arroja el error de las gems.

como puedo saber desde ssh que version de gems tengo??

Saludos y gracias

como puedo saber desde ssh que version de gems tengo??

Creo que con “gem list” y miras “rubygems-update”.

Realmente basta con “gem -v”

Miguel M. wrote:

al utilizar el plugin file_column para subir
archivos, me arroja un error de que Rmagick no existe. (este plugin lo
subi a mano por ftp)

¿Has instalado Rmagick?

como puedo saber desde ssh que version de gems tengo??

Creo que con “gem list” y miras “rubygems-update”.

Puede que tengas que poner en algún sitio la ruta a rubygems, puede que
en alguna variable de entorno. Mira en el wiki de Dreamhost a ver si ves
algo.

Hola, si tienes razon , lo solucioné . instale ruby , y gems, y edite
las
variables de entorno en mi servidor y en el environment.rb

en el wiki esta toda la informacion, muchas gracias.

lo unico que no me resulta es realizar scaffolds desde el ssh de mi
cuenta
de usuario.
me sale un error de conexion , pero las aplicaciones me funcionan , si
las
subo, y ademas logré instalar plugins desde ssh, que es lo que queria
hacer

gracias por la ayuda

no he instalado el Rmagick, pero desde ssh si hago un convert -version,
obtengo lo siguiente

Version: ImageMagick 6.2.4 09/16/06 Q16 http://www.imagemagick.org
Copyright: Copyright © 1999-2005 ImageMagick Studio LLC

creo que no es la ultima version, ¿puede ser que por eso que el
file_column
me arroja el error de que falta el Rmagick?

con respecto a los de rubygems, ejecute los comando que me dices pero
obtengo estos resultados

[zagnut]$ gem list
/usr/bin/gem:9:in `require’: no such file to load – rubygems
(LoadError)
from /usr/bin/gem:9

[zagnut]$ gem -v
/usr/bin/gem:9:in `require’: no such file to load – rubygems
(LoadError)
from /usr/bin/gem:9

aunque si hago un locate rubygems

encuentro esto

/usr/local/lib/site_ruby/1.8/rubygems

que son las carpetas de arriba de mis carpetas,

[zagnut]$ cd /usr/local/lib/site_ruby/1.8/rubygems
[zagnut]$ ls
builder.rb gem_commands.rb remote_fetcher.rb
specification.rb
cmd_manager.rb gem_open_uri.rb remote_installer.rb
timer.rb
command.rb gem_openssl.rb rubygems_version.rb
user_interaction.rb
config_file.rb gem_runner.rb security.rb
validator.rb
custom_require.rb installer.rb server.rb
version.rb
dependency_list.rb old_format.rb source_index.rb
doc_manager.rb open-uri.rb source_info_cache.rb
format.rb package.rb source_info_cache_entry.rb

creo que tendré que instalar el rmagick y el gems en mi espacio de
servidor
¿que opinan, vale la pena hacerlo , o hay otra manera?

gracias por la ayuda

Saludos

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs