Problema de versiones al instalar rails 1.2.2

Hola lista,
tengo un miniproblema con la instalación.
Estoy en Ubuntu Festy.
Tengo que instalar ruby1.8.5, gem 0.9.0 y rails1.2.2 (es para pruebas
en local con las mismas versiones que hay en producción)
Soy novatillo en rails osea que igual digo alguna burrada…
He instalado correctamente ruby1.8.5(por defecto) y gem 0.9.0, pero al
hacer “sudo gem install rails --include-dependencies” me ha instalado
rails 2.xx.
La he desinstalado con “sudo gem uninstall rails”, y luego he instalado
la 1.2.2 con “sudo gem install rails -v1.2.2 --include-dependencies”,
pero tengo unproblema, que son las versiones de las gemas instaladas.
Creo que me ha dejado las gemas que se instalan con rails2. Como puedo
downgradear las gemas? o como puedo desinstalar las dependencies de
rails2 para volver a instalar desde cero?
Por ejemplo, quiero “actionmailer (1.3.2, 1.2.5)” y tengo “actionmailer
(2.0.2, 1.3.2)”
O igual me decis que da igual, que eso quiere decir que tengo las dos
versiones y me va a funcionar igual…
si alguien me puede ayudar, se lo agradezco.

Con …

gem uninstall rails

Te aparecera una lista con las versiones que tengas instaladas y
escoges lo que quieres eliminar.

Un saludo,

Cesc

On Dec 21, 2007, at 3:57 PM, Igor O. wrote:

pero tengo unproblema, que son las versiones de las gemas instaladas.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí
voice. +34 678.681.603

El Fri, 21 Dec 2007 16:01:46 +0100
Francesc E. [email protected] escribió:

Con …

gem uninstall rails

Te aparecera una lista con las versiones que tengas instaladas y
escoges lo que quieres eliminar.
Si, pero eso no desinstala las dependencias instaldas, ¿importa o no
importa?

Gracias, ahora ya lo tengo claro.

El Sat, 22 Dec 2007 11:55:14 +0100
Francesc E. [email protected] escribió:

Un detalle. En tu aplicación Rails tu has de tener definido que
version de estas utilizando. (Fichero config/environment.rb)

RAILS_GEM_VERSION = ‘1.2.2’ unless defined? RAILS_GEM_VERSION

Tu despues puedes instalar las versiones que quieras de Rails en tu
máquina que tu aplicación cargarà la requerida con sus dependecias.

Un saludo,

Francesc

On Dec 21, 2007, at 4:09 PM, Igor O. wrote:

Si, pero eso no desinstala las dependencias instaldas, ¿importa o no

Tengo que instalar ruby1.8.5, gem 0.9.0 y rails1.2.2 (es para
como puedo desinstalar las dependencies de rails2 para volver a
http://lists.simplelogica.net/mailman/listinfo/ror-es
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es


name. Francesc E. i Martí
voice. +34 678.681.603

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs