Problema con las gems

Saludos,

Por alguna razon que desconozco, no me deja instalar ninguna gem. Los
pasos que seguí fueron los siguientes:

si hago gem -v, me dice que tengo la version 1.3.6, todo correcto en
principio. Pero cada vez que me intento instalar un gem (por ejemplo,
rails) me sale: ERROR: could not find gem rails locally or in a
repository.

Bueno, para mas info, os pego el resultado al hacer gem env:

RubyGems Environment:

Has encontrado la solución?? A mi me pasa lo mismo, y es muy raro. Si
ejecuto esto:

[email protected]:~$ gem list -r authlogic

*** REMOTE GEMS ***

authlogic (2.1.3)
authlogic-oauth (1.0.8)
authlogic-oid (1.0.4)
authlogic_facebook (1.0.5)
authlogic_haapi (1.0.4)
authlogic_pam (0.1.0)
authlogic_rpx (1.1.1)
authlogic_wind (0.4.0)

Y en cambio, cuando intento instalar authlogic, este es el resultado:

[email protected]:~$ sudo gem install -r authlogic_facebook
–include-dependencies
INFO: gem install -y is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: could not find gem authlogic locally or in a repository

Un saludo

Mc Hammer wrote:

Bueno, para mas info, os pego el resultado al hacer gem env:

RubyGems Environment:

Hola, tio mira por que no intentas probar con el comando gem update
–system yo asi actualize a la ultima version de rubyGem y no me dio
problemas y despues desinstale la version vieja de rails y la volvi a
instalar y ya!

Prueba y nos dices, que como te repito asi hice y no me dio problemas.

Bendiciones!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs