Problema al iniciar rails en linux mint


#1

Creo el proyecto y hasta ahi todo bien, pero cuando voy a inicar el servidor con rails s este me indica que tengo instalar gemas, utilizo el bundle install y me aparece el siguiente error:
An error occurred while installing nokogiri (1.8.4), and Bundler cannot continue.
Make sure that gem install nokogiri -v '1.8.4' --source 'https://rubygems.org/' succeeds before bundling.

In Gemfile:
rails was resolved to 4.2.10, which depends on
actionmailer was resolved to 4.2.10, which depends on
actionpack was resolved to 4.2.10, which depends on
actionview was resolved to 4.2.10, which depends on
rails-dom-testing was resolved to 1.0.9, which depends on
nokogiri

Agradezco la ayuda que me puedan ofrecer.


#2

Prueba esto:

gem install nokogiri -v '1.8.4' -- --use-system-libraries

Sino funciona porfavor indica tu version de Ruby, sistema operativo & como as instalado Ruby.


#3

Estoy usando ruby 2.5.1 y esta es la version del linux

Distributor ID: LinuxMint
Description: Linux Mint 19 Tara
Release: 19
Codename: tara

La instalacion la realize con RVM desde la pagina oficial.

Pero fijate que cuando creo un proyecto: rails new prueba. carga correcto . pero cuando le indico que el manejador de base de datos es mysql me da este error…


#4

Prueba este comando:

bundle config build.nokogiri --use-system-libraries
bundle install

Pega aqui el error completo sino funciona.