Problem with Wx Gui FFT

Hi,

recently I upgraded my PC to Ubuntu 13.04. After that, I also updated
the
GNU Radio + UHD installation. Almost everything is working. A problem
that
appeared is that the Wx Gui FFT is not showing the chart.

As is said: an image is worth a thousand words. So I attached the
uhd_fft
execution.

Any sugestions? I’m missing a compiling parameter or something?

http://gnuradio.4.n7.nabble.com/file/n41275/gnuradio.jpg


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On Mon, May 13, 2013 at 5:27 PM, maiconkist [email protected]
wrote:

http://gnuradio.4.n7.nabble.com/file/n41275/gnuradio.jpg

I had the same problem on computers with Nvidia and AMD/ATI cards
using the open source driver. Apparently, the open source driver has
forgotten how to do opengl. I managed to find a closed source driver
which gave me flickering wxgui FFT, but that’s all.

Alex

Hi,

I’m having the same trouble on Ubuntu 12.04 LTS x64 after playing with
the
AMD/ATI drivers.

The quick solution is to add the following to ~/.gnuradio/config.conf :

[wxgui]
style=nongl

Regards,

Mike


Mike J. M0MIK BSc MIET
Email: [email protected]
Web: http://scanoo.com

Regards,

Mike
Note that you lose some functionality when going to the non-gl versions
of wxGui. Including waterfall displays, and the “click to X” stuff
that’s
available on the openGL side.


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

Hi Mike,

thank for you reply. But with this option the uhd_fft crashes. The
following
is thrown in the terminal: AttributeError: ‘gr_hier_block2_sptr’ object
has
no attribute ‘set_callback’

More info about my machine: Ubuntu 13.04 with KDE and a Intel i915
graphics
card.

On Mon, May 13, 2013 at 4:52 PM, Alexandru C. <[email protected]> wrote:

uhd_fft
which gave me flickering wxgui FFT, but that’s all.

Alex


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41281.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Hi,

I believe that error is due to me experimenting with the uhd_fft ‘click
on
fft to change frequency’ feature. Are you using the current master
branch
as this contains Marcus L.'s fix for it.

Cheers,

Mike


Mike J. M0MIK BSc MIET
Email: [email protected]domain.invalid
Web: http://scanoo.com

Hi Mike,

thank for you reply. But with this option the uhd_fft crashes. The following
is thrown in the terminal: AttributeError: ‘gr_hier_block2_sptr’ object has
no attribute ‘set_callback’

More info about my machine: Ubuntu 13.04 with KDE and a Intel i915 graphics
card.

That would mean that you’re running a Gnu Radio that is out of date by a
couple of months.


Marcus L.
Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

Hi Mike,

I recompiled the source today again. The problem continues.

The builddate is: Mon, 13 May 2013 13:37:52

Is worth recompiling again?

Thanks


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41285.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On Tue, May 14, 2013 at 2:01 AM, Mike J. [email protected] wrote:

I’m having the same trouble on Ubuntu 12.04 LTS x64 after playing with the
AMD/ATI drivers.

The quick solution is to add the following to ~/.gnuradio/config.conf :

[wxgui]
style=nongl

This works, but the non-GL sinks are terribly out-of-date, and the only
reason we haven’t removed them from the codebase is that they provide
this
important fallback when OpenGL is not working on a user’s machine.

I’d like to understand more about the actual problem–I only use 12.04
and
12.10 so I can’t duplicate it.

style=nongl


Johnathan C.
Corgan Labs - SDR Training and Development Services
http://corganlabs.com


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
The reported error should have been fixed in:

commit 50d9b3282ae65b7cf6bf007ab8f32b4ae7cc3ed1

The problem is that if you have an app that makes use of the
“set_callback” feature, prior to that commit, it would provoke an
exception if you were
using the non-gl implementations of the FFT GUI sink for wxGUI,
because the non-gl version didn’t have the necessary “set_callback()”
method.

Marcus,

I downloaded and compiled it directly from the official git repository.

Thanks


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41283.html
Sent from the GnuRadio mailing list archive at Nabble.com.

exception if you were

Johnathan C.
Corgan Labs - SDR Training and Development Services
http://corganlabs.com
Oh, well, for that I have no clue :slight_smile:

GL is a festering swamp, as are display drivers. But I guess this boils
down to “what part of the festering swamp do we need to look at, and are
we provoking it?”

I wonder if in gnuradio/gr-wxgui/scr/python/plotter/plotter_base.py the
attribList could be checked?
static bool IsDisplaySupported(const int *attribList)
http://docs.wxwidgets.org/trunk/classwx_g_l_canvas.html

Patrik

On Tue, May 14, 2013 at 4:48 AM, Marcus D. Leech [email protected]
wrote:

I get this part, thanks. I’m interested in understanding the
“flickering
FFT” problem with the GL-based sinks after upgrading to 13.04. It’s the
second time it’s been reported on the list.

On 14 May 2013 10:08, maiconkist wrote:

I recompiled all again
last night. Build version 3.6.4.1-203-g0641a449. The
problem
continues.

The suggestion with the ‘[wxwidgets] style=nongl’ didn’t
work for me.

OpenGL is working fine here. All 3D desktop effects
works and glxgear runs
fine.

Any clue about this problem ?

View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41310.html

Sent from the GnuRadio mailing list archive at Nabble.com.


Discuss-gnuradio
mailing list
[email protected]

https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Do you perhaps
also have an installed-from-packaged-binaries Gnu Radio installation?

Hi Marcus,

double checked this, gnuradio from repository is not installed.

I notifice that when I click the close button in the uhd_fft window, for
an
instant the FFT plot is shown.

Thanks.


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41312.html
Sent from the GnuRadio mailing list archive at Nabble.com.

I’m not sure but shouldn’t the category be [wxgui] and not [wxwidgets]
in ~/.gnuradio/config.conf?
see in your gnuradio/gr-wxgui directory the readme’s

From the command line you can lower the fft-rate and increase the
avg-alpha, example
$ uhd_fft --fft-rate=10 --avg-alpha=0.3 etc
Increase the fft-rate until your window become unresponsive

Patrik

Best Regards,
Patrik T.

POES-Weather Ab Ltd Remote Sensing
Business id: FI 23624190
CEO Patrik T.
GSM: +358 40 833 11 70
Street address: Furuskogsvgen 89
Postal code: 65280
City: Vasa
Country: Finland
Web: poes-weather.com

I recompiled all again last night. Build version 3.6.4.1-203-g0641a449.
The
problem continues.

The suggestion with the ‘[wxwidgets] style=nongl’ didn’t work for me.

OpenGL is working fine here. All 3D desktop effects works and glxgear
runs
fine.

Any clue about this problem ?


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41310.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On 14 May 2013 11:29, maiconkist wrote:

Hi Patrick,

my
mistake, the correct is ‘wxgui’, as you said.

This solved my
problem. Yesterday I cloned and compiled the gnuradio sources
by
myself, instead of using the script provided by in the official site.
I
notice that the script doesn’t compile the master branch. The script
did a
checkout in the “maint” branch. Probably the problem was not
fixed in this
branch yet.

Confirming the solution then:

Put
this in the “~/.gnuradio/config.conf” file:

[wxgui]
style=nongl

Thanks everybody .

You can use the “-m” option on build-gnuradio now
to cause it to use “master” instead of “maint”.

I’m surprised that my
fix for the set_callback() problem wasn’t propagated to “maint” – it
went into “master” some time ago.

Hi Patrick,

my mistake, the correct is ‘wxgui’, as you said.

This solved my problem. Yesterday I cloned and compiled the gnuradio
sources
by myself, instead of using the script provided by in the official site.
I
notice that the script doesn’t compile the master branch. The script did
a
checkout in the “maint” branch. Probably the problem was not fixed in
this
branch yet.

Confirming the solution then:

Put this in the “~/.gnuradio/config.conf” file:

[wxgui]
style=nongl

Thanks everybody .


View this message in context:
http://gnuradio.4.n7.nabble.com/Problem-with-Wx-Gui-FFT-tp41275p41314.html
Sent from the GnuRadio mailing list archive at Nabble.com.