Problem with vim and SimpleFold


#1

Hi,

I just started using the SimpleFold [1] plugin with vim 6.4.
When I start vim I get the following error:

E518: Unknown option: completefunc=10_RCT_completion

My .vimrc contains
map f SimpleFold_Foldsearch
" fold when switching to that buffer
“au Filetype ruby call SimpleFold_Foldsearch(”")

Question 1: What do I have to do to make that annoying error go away?

Question 2: If I uncomment the last line, the plugin should be used on
each freshly loaded ruby file. However vim complains, that the plugin is
unknown. How do I change that?

Happy rubying,
Guido

[1] http://eigenclass.org/hiki.rb?simplefold+plugin+0.4.0


#2

On Wed, Jan 03, 2007 at 07:05:09AM +0900, Guido wrote:

I just started using the SimpleFold [1] plugin with vim 6.4.
When I start vim I get the following error:

E518: Unknown option: completefunc=10_RCT_completion

This comes from the rcodetools plugin. completefunc was added in vim 7.0
and
isn’t thus available in 6.4. You can get rid of the error by commenting
the
corresponding line in ~/.vim/plugin/rcodetools.vim:

"execute “au Filetype ruby setlocal completefunc=” . s:sid .
“RCT_completion”

My .vimrc contains
map f SimpleFold_Foldsearch
" fold when switching to that buffer
“au Filetype ruby call SimpleFold_Foldsearch(”")

Question 1: What do I have to do to make that annoying error go away?

For the time being just edit rcodetools.vim; I’ll add some code to
detect the
vim version and skip the completefunc for vim < 7.0 in the next release.

Question 2: If I uncomment the last line, the plugin should be used on
each freshly loaded ruby file. However vim complains, that the plugin is
unknown. How do I change that?

This should do (it works for me) if you’re using the f mapping.

" fold when loading Ruby files
au Filetype ruby execute "normal " . mapleader .“f”

HTH,


#3

Thanks a lot for your help!

Am Wed, 03 Jan 2007 08:38:29 +0900 schrieb Mauricio F.:

Question 1: What do I have to do to make that annoying error go away?
solved :slight_smile:

Question 2: If I uncomment the last line, the plugin should be used on
each freshly loaded ruby file. However vim complains, that the plugin is
unknown. How do I change that?

This should do (it works for me) if you’re using the f mapping.

" fold when loading Ruby files
au Filetype ruby execute "normal " . mapleader .“f”

Somehow this doesn’t work, vim complains that the variable mapleader is
undefined. However it’s not much trouble to just press \f on loading, so
maybe I’ll just go with that and hope I can get vim7 soon :slight_smile:

Thanks!
Guido


#4

(oops, I forgot this in +postponed)

On Wed, Jan 03, 2007 at 06:45:06PM +0900, Guido wrote:

This should do (it works for me) if you’re using the f mapping.

" fold when loading Ruby files
au Filetype ruby execute "normal " . mapleader .“f”

Somehow this doesn’t work, vim complains that the variable mapleader is
undefined. However it’s not much trouble to just press \f on loading, so
maybe I’ll just go with that and hope I can get vim7 soon :slight_smile:

Maybe an extra indirection level?
execute “au Filetype ruby execute ‘normal " . mapleader . "f’”

works for me (but so does the above line, with vim 7)


#5

Hello,
My two cents. Install VIM 7.0.x. Here is a link that I followed
without any problems. Works like a charm. I am assuming that you are
on a linux/unix system?
http://beans.seartipy.com/2006/09/22/develop-ruby-applications-using-vim-70-editor/
Regards,
Bharat