Problem with TCP Source and TCP Sink Block

Hi

I am using GNU Radio 3.6.4.2 on Ubuntu 12.04. I am unable to use the TCP
Source and Sink blocks which I want to connect to hardware. Whenever I
use them, I get the following error:

File “/home/vlab/Documents/top_block.py”, line 13, in
from grc_gnuradio import blks2 as grc_blks2
File
“/usr/local/lib/python2.7/dist-packages/grc_gnuradio/blks2/init.py”,
line 22, in
from packet import options, packet_encoder, packet_decoder,
File
“/usr/local/lib/python2.7/dist-packages/grc_gnuradio/blks2/packet.py”,
line 21, in
from gnuradio import gr, digital
ImportError: cannot import name digital

Could you please help me out?

Thanks

Anamay Kane

Hi Anamay Kane,

that seems to be an installation issue.

Generally. GNU Radio 3.6.4.2 is outdated. If you need the 3.6 API, use
the latest version from the 3.6 branch, which is 3.6.5.1. But that is
not very likely to see updates/bugfixes in the future.

If you can, try to use GNU Radio 3.7. If you don’t have to work with
very complex existing GNU Radio modules that need GNU Radio 3.6, now
would be a good time to switch to 3.7.

The problem you’re seeing is unrelated to the TCP sink/source. It’s just
that python says the gnuradio module doesn’t have a “digital” submodule.
Did you build this flow graph yourself or did you get if from somewhere
else?

Best regards,
Marcus

PS: By the way: though Ubuntu 12.04LTS is still supported by GNU Radio,
it’s really old – maybe you’d want to switch to at least GNU Radio
14.04LTS by now.

Hi Marcus,

is it possible to remove GNURadio from 12.04 with apt-get and install
the GNURadio 3.7 branch with pybombs without switching to Ubuntu 14 ? I
dont know if the dependencies are ok for 3.7 in 12.04.

regards,
Andy

Am 03.07.2015 um 18:36 schrieb Marcus M.:

I haven’t tested that myself, but I’ve been told pybombs does target
Ubuntu 12.04. It will install a hell of a lot of manually built
dependencies into your prefix (which would be available for installation
from package repositories on “modern” Ubuntus), but it should work.
3.7 is the default for pybombs, by the way.

Best regards,
Marcus

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs