Problem with starting mongrel gem

Hi,

I have installed mongrel gem and when i tried to start
mongrel_rails start its causing me following problem

mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Requiring REXML
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/
active_support/dependencies.rb:239:in require': no such file to load -- dispatcher (LoadError) from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/ active_support/dependencies.rb:239:inblock in require’
from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/
active_support/dependencies.rb:225:in block in load_dependency' from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/ active_support/dependencies.rb:593:innew_constants_in’
from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/
active_support/dependencies.rb:225:in load_dependency' from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.10/lib/ active_support/dependencies.rb:239:inrequire’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/
mongrel/rails.rb:148:in rails' from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/ mongrel_rails:116:inblock (2 levels) in run’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/
mongrel/configurator.rb:149:in call' from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/ mongrel/configurator.rb:149:inlistener’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/
mongrel_rails:102:in block in run' from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/ mongrel/configurator.rb:50:incall’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/
mongrel/configurator.rb:50:in initialize' from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/ mongrel_rails:86:innew’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/
mongrel_rails:86:in run' from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/lib/ mongrel/command.rb:210:inrun’
from /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.2.0.pre2/bin/
mongrel_rails:282:in <top (required)>' from /usr/local/bin/mongrel_rails:19:inload’
from /usr/local/bin/mongrel_rails:19:in `’

Could any one provide me solution,

thanks,
-pab

On Dec 15, 2:44am, Pab [email protected] wrote:

active_support/dependencies.rb:239:in `require’: no such file to load
– dispatcher (LoadError)

Mongrel doesn’t work with newer versions of Rails (old supported one
was 2.2 I think)

Could any one provide me solution,

Use thin or passenger standalone.


Luis L.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs