Problem with ssh -> authentication failed


#1

Hi,

i have a very stupid and annoying problem;/ I wrote a simple script:

require ‘rubygems’
require ‘net/ssh’

Net::SSH.start(‘host’,:username => ‘user’,:password => ‘pass’) do
|session|

shell=session.shell.open

shell.dir
shell.exit

$stdout.print shell.stdout while shell.stdout?
$stderr.puts “-- stderr: --”
$stderr.print shell.stderr while shell.stderr?

end

All the time I have the same error:

c:/ruby/lib/ruby/gems/1.8/gems/net-ssh-2.0.4/lib/net/ssh.rb:195:in
`start’: Net::SSH::AuthenticationFailed

I tried a lot of diffrent script with ssh, but all the time I have still
the same error

Any suggestions what’s wrong ??

THX


#2

c:/ruby/lib/ruby/gems/1.8/gems/net-ssh-2.0.4/lib/net/ssh.rb:195:in
`start’: Net::SSH::AuthenticationFailed

Any suggestions what’s wrong ??

I apologise for stating the obvious, but it looks like a wrong username
and/or password. Or it could be that there is something else at the
server side which is rejecting the connection, e.g. it’s possible to
configure ssh accounts so they only accept connections from a particular
IP address, or so that they can only run certain commands (not shells).

Looking at sshd logs on the far side could help to determine the
problem. Even better, try running sshd in debug mode, bound to a
different port:

sshd -d -p 99

This will stay in the foreground without forking, and show you the
processing of incoming connections. Add :port=>99 to your client of
course.