Problem with running rake db:migrate on a Rails app


#1

Hi everybody,

I am trying to get the Typo blog engine up and running in development
mode but I hit the wall as early as running rake db:migrate:

(in /home/tweisser/workspace/typo/typo)
rake aborted!
no such file to load – spec/rake/spectask
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in gem_original_require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:31:inrequire’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:521:innew_constants_in’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
require' /home/tweisser/workspace/typo/typo/lib/tasks/rspec.rake:9 /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:142:inload_without_new_constant_marking’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:142:in load' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:521:innew_constants_in’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:142:in load' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rails-2.2.2/ lib/tasks/rails.rb:8 /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rails-2.2.2/ lib/tasks/rails.rb:8:ineach’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rails-2.2.2/
lib/tasks/rails.rb:8
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in gem_original_require' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:31:inrequire’
/home/tweisser/workspace/typo/typo/Rakefile:10
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/
lib/rake.rb:2349:in load' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/ lib/rake.rb:2349:inraw_load_rakefile’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/
lib/rake.rb:1985:in load_rakefile' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/ lib/rake.rb:2036:instandard_exception_handling’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/
lib/rake.rb:1984:in load_rakefile' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/ lib/rake.rb:1969:inrun’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/
lib/rake.rb:2036:in standard_exception_handling' /opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/ lib/rake.rb:1967:inrun’
/opt/ruby-enterprise-1.8.6-20090201/lib/ruby/gems/1.8/gems/rake-0.8.3/
bin/rake:31
/opt/ruby-enterprise/bin/rake:19:in `load’
/opt/ruby-enterprise/bin/rake:19

You can see which version of Ruby I’m running. It’s symlinked by /opt/
ruby-enterprise with /opt/ruby-enterprise/bin in my $PATH.

I have the latest version of gem and these gems installed:

*** LOCAL GEMS ***

actionmailer (2.2.2)
actionpack (2.2.2)
actionwebservice (1.2.6)
activerecord (2.2.2)
activeresource (2.2.2)
activesupport (2.2.2)
capistrano (2.5.4)
highline (1.5.0)
mysql (2.7)
net-scp (1.0.2)
net-sftp (2.0.2)
net-ssh (2.0.10)
net-ssh-gateway (1.0.1)
rails (2.2.2)
rake (0.8.3)
rspec (1.1.12)
will_paginate (2.2.2)

I don’t know what’s wrong here.

Did anybody encounter this problem elsewhere? I have little to no
Rails debugging experience with current Rails versions. Where to
start?

Thanks for your help.

Tobias


#2

Rake is trying to find rspec and isn`t being able to do it. Do you
have any other rails version available? Are you sure that the rspec
gem is installed at your current Ruby interpreter?

You could also try to unpack the rspec gem into vendor/gems in your app.

Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) | http://blog.codevader.com/
(en)


#3

It’s a weird problem.

rspec is installed for sure. I can use it in other Rails apps locally
from within the same Ruby/Rails setup.

I tried adding a git submodule for rspec to vendor/gems/rspec from the
rspec github page. Still, the same errors.

I switched back to Ubuntu’s Ruby installation to try if this made a
difference, but the problem remains the same. It just affects Typo.
Other Rails apps work fine…

Thanks for your help,

Tobias

On Feb 22, 4:46 am, Maurício Linhares removed_email_address@domain.invalid


#4

I’d recommend that you take a look at this:

http://wiki.github.com/dchelimsky/rspec/rails-with-rspec-gems

It should help you get rspec working.

–Matt J.


#5

Your local gem is REE’s gem repository or MRI’s? Thats easy to be
confused indeed… and seems when I tried something like rake
gems:install in rails project it would always install the gem inside
MRI unless you have replace the static link of rake/gem/ruby. (Yep, I
am explicitly calling the rake inside REE.)