Problem with rubygems (and postgres)

Hi,

I’ve got Ruby 1.8.4 compiled and installed on a Ubuntu box. I
installed rubygems 0.8.11. I then installed the postgres gem.
Everything went ok. Doing a “gem list postgres” shows the postgres
gem.

So, when I fire up irb and do

irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘postgres’
LoadError: no such file to load – postgres
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from (irb):2

That’s not good. Why???!

Thanks,
Joe

On Tue, 4 Jul 2006, Joe Van D. wrote:

=> true

That’s not good. Why???!

Thanks,
Joe

do you have two instances of ruby installed? perhaps /usr/bin/ruby and
/usr/local/bin/ruby?

if so you probably also have

/usr/bin/gem

but only

/usr/local/bin/irb

regards.

-a

On 7/3/06, [email protected] [email protected] wrote:

  from (irb):2

if so you probably also have

/usr/bin/gem

but only

/usr/local/bin/irb

I did have the Ubuntu-installed Ruby installed at one point, but I
removed it. I thought I had removed all traces of it. Maybe not.
/usr/bin/ruby, /usr/bin/gem, and /usr/lib/ruby don’t exist.

On 7/3/06, Joe Van D. [email protected] wrote:

So, when I fire up irb and do
`require’

/usr/bin/ruby, /usr/bin/gem, and /usr/lib/ruby don’t exist.
For some reason, downloading ruby-postgres-20060406.tar.gz and doing a
manual install worked, while installing with the gem did not.

Now, I’ve got to figure out why I’m getting:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- test/rails (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
/home/joe/projects/tanga/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:147:in
`require’
from ./test/integration/…/test_helper.rb:4
from ./test/integration/layout_test.rb:1
from
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/rake_test_loader.rb:5
from
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/rake_test_loader.rb:5
rake aborted!

Whenever I try to run any unit tests…

On Tue, 4 Jul 2006, Joe Van D. wrote:

For some reason, downloading ruby-postgres-20060406.tar.gz and doing a
manual install worked, while installing with the gem did not.

oh yeah. i remember that i had the same problem - the compilation stage
of
the gem install doesn’t correctly configur the include and lib dirs and
thus
is fails (silently).

fyi for people reading this…

-a

On Jul 3, 2006, at 12:10 PM, Joe Van D. wrote:

dependencies.rb:147:in
Whenever I try to run any unit tests…
test/rails comes from ZenTest.


Eric H. - [email protected] - http://blog.segment7.net
This implementation is HODEL-HASH-9600 compliant

http://trackmap.robotcoop.com

just a fyi, but i had the same issue hours ago on a fedora box and got
it
working using

gem install postgres – --with-pgsql-dir=/usr/local/pgsql

(extra – is correct),then manually making it…

cd /usr/local/lib/ruby/gems/1.8/gems/postgres-0.7.1/
ruby extconf.rb
–with-pgsql-include-dir=/usr/local/pgsql/include
–with-pgsql-lib-dir=/usr/local/pgsql/lib

obvious path changes as req., sorry 'bout the breaks
(info found @
http://www.nostalgix.org/blog/2005/06/hack-lot-ruby-on-rails-tiger-and.html)

might have been easier using the tarball… :stuck_out_tongue:

sorry, must be sleeping - final step is to

make install

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs