Problem with RubyForge and gems

All,

Just to let you know there is an unknown problem right now with the
gems service on RubyForge that folks thought was Leopard related but
its not…I get the same thing in Tiger (and other OSes may get the
same):

gem search --remote jabber

*** REMOTE GEMS ***
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (TypeError)
can’t instantiate uninitialized class

We will identify the problem as soon as is possible and fix it…just
want to let folks know so you can know that your shinny new OS is OK :wink:

Best,

Rich

We’ve identified the problem and its being fixed as we … email :slight_smile:

Go Tom!

-rich

Richard K. wrote:

We’ve identified the problem and its being fixed as we … email :slight_smile:

I BROKE RUBYFORGE! Briefly.

In fact, the problem was me (unless it was the indexer, but I’m pretty
sure it was me). I uploaded a gem (win32-api 1.0.4) using a beta version
of rubygems, and that wreaked holy havoc.

Just in time for Leopard Day! Woohoo! :expressionless:

As luck would have it Tom and I were both on IRC, and the problem was
fixed about an hour after it was discovered. So a big thank you to Tom
Copeland! And also to Tim Pope (also on IRC) who figured out that it was
my gem causing the problem.

SORRY EVERYONE!!!

Hopefully you were all out drinking on a Friday night and never noticed.

Apologies,

Dan

PS - This will mean some discussion on the rubygems-devel list as far as
fixes and/or a release strategy. :slight_smile:

On Oct 26, 2007, at 10:04 PM, Richard K. wrote:

We’ve identified the problem and its being fixed as we … email :slight_smile:

thanks a million guys - you are heros.

a @ http://codeforpeople.com/

From: Daniel B. [mailto:[email protected]]

I BROKE RUBYFORGE! Briefly.

that is interesting. how could one gem bring down the whole repository??
(dangerous, so to speak)

thanks and kind regards -botp

Peña wrote:

From: Daniel B. [mailto:[email protected]]

I BROKE RUBYFORGE! Briefly.

that is interesting. how could one gem bring down the whole repository?? (dangerous, so to speak)

thanks and kind regards -botp

I’m not entirely sure yet. It may have been because I used a new
constant (Gem::Platform::CURRENT I think) for the gem.platform, which
isn’t supported by 0.9.4 afaik.

We’ll have to discuss this on the list and keep everyone posted. In the
meantime, the RF gem indexer won’t run for 24 hours, just to make sure
no one else does the same thing and has time to see this message and/or
the one on rubygems-devel.

Regards,

Dan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs