Problem with path


#1

Hey there,

i tried to include libs in my ruby file, just as ruby cookbook shows,

require ‘rubygems’
request ‘win32/service’
include Win32

after run, it shows error msg, ‘require’ no such file to load -
win32/service

I check the lib folder, service.rb is not under the regular lib path,
which is C:\Ruby\lib\ruby\1.8.

I found service.rb in
C:\Ruby\lib\ruby\gems\1.8\gems\windows-pr-0.9.3\lib\windows and in the
file, it requires “windows/api”, which i can only find it in
C:\Ruby\lib\ruby\gems\1.8\gems\windows-api-0.2.4\lib\windows.

So, I don’t know how to make the file work since the required files are
all over the places.


#2

Seems it should be

require ‘windows/service’


#3

Alex 2k8 wrote:

Seems it should be

require ‘windows/service’

No, I reinstalled the lib by keying command line gem install
win32-service-0.6.1-x86-mswin32-60.gem. It was sucessfully installed.

I checked the lib path, it is
“C:\ruby\lib\ruby\gems\1.8\gems\win32-service-0.6.1-x86-mswin32-60\lib\win32”…


#4

Cheyne Li wrote:

No, I reinstalled the lib by keying command line gem install
win32-service-0.6.1-x86-mswin32-60.gem. It was sucessfully installed.

I checked the lib path, it is
“C:\ruby\lib\ruby\gems\1.8\gems\win32-service-0.6.1-x86-mswin32-60\lib\win32”…

This will work
require ‘win32/service’

Basically, you have
‘lib\win32\service.rb’
‘lib\win32\daemon.so’

so you can use
require ‘win32/service’
require ‘win32/daemon’