Problem with "open_id_authentication" plugin

I just install the plugin.

I didn’t do anything first ( should I? ).

And try “rails server”

And this is what I got (error part):

C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:in
require': no such file to load -- openid (LoadError) from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:inblock in require’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:225:in
block in load_dependency' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:596:innew_constants_in’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:225:in
load_dependency' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:inrequire’
from
D:/cfecardgame/vendor/plugins/open_id_authentication/lib/open_id_authentication.rb:2:in
<top (required)>' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:inrequire’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:in
block in require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:225:inblock in load_dependency’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:596:in
new_constants_in' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:225:inload_dependency’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/activesupport-3.0.6/lib/active_support/dependencies.rb:239:in
require' from D:/cfecardgame/vendor/plugins/open_id_authentication/init.rb:5:inblock in class:Plugin
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/plugin.rb:81:in
eval' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/plugin.rb:81:inblock in class:Plugin
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/initializable.rb:25:in
instance_exec' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/initializable.rb:25:inrun’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/initializable.rb:50:in
block in run_initializers' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/initializable.rb:49:ineach’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/initializable.rb:49:in
run_initializers' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/application.rb:134:ininitialize!’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/application.rb:77:in
method_missing' from D:/cfecardgame/config/environment.rb:5:in<top (required)>’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/application.rb:103:in
require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/application.rb:103:inrequire_environment!’
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/railties-3.0.6/lib/rails/commands.rb:22:in
<top (required)>' from script/rails:6:inrequire’
from script/rails:6:in `’

problem solved by adding two line in gemfile:

gem ‘ruby-openid’
gem ‘rack-openid’

sorry for asking the stupid question…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs