Problem with mailman behind nginx with TLS certs

mailman version 2.1.22 works fine for my webpages I set up such as
http://cibolo.us/mailman/listinfo/open_electroporator that URl is
rewritten and permenanently directed to below:
https://cibolo.us/mailman/listinfo/open_electroporator

The problem is with the moderation page. When submitting a change,
a security warning pops up saying info will not be encrypted,
I click continue,

The radio button for discard goes back to Defer, the state it was in
before.

All other functions of the admin pages work normally except for this.

Do you think some special rewrite is needed for
https://cibolo.us/mailman/admindb/sandbox
the URl that has this problem? (All lists on this server have this
problem).

Thanks,
John Griessen

=================================================================

I checked and my configuration had:
DEFAULT_URL_HOST = ‘cibolo.us
DEFAULT_URL_PATTERN = ‘http://%s/mailman/’
DEFAULT_EMAIL_HOST = ‘cibolo.us
MTA=‘Postfix’

nginx was set to serve www.cibolo.us and cibolo.us by redirecting to
https://cibolo.us

the subdirectories are set to be rewritten as in
https://www.nginx.com/resources/wiki/start/topics/recipes/mailman/

location /mailman
location /images/mailman
location /pipermail

After noting these settings, I reran

sudo /usr/sbin/withlist -l -r fix_url sandbox

then cleared the browser cache,
then browsed
https://cibolo.us/mailman/listinfo

where I see an overall lists list

I use those links to navigate to

https://cibolo.us/mailman/listinfo/sandbox
https://cibolo.us/mailman/admin/sandbox
https://cibolo.us/mailman/admindb/sandbox

and when I change action to take to discard
and click submit,

a security warning pops up saying info will not be encrypted,
I click continue,

The radio button for discard goes back to Defer, the state it was in
before.

All other functions of the admin pages work normally except for this.

=======================================================
If I change nginx to not redirect, but serve http without TLS certs when
asked,
the user interface for moderation works normally.

John Griessen:

I checked and my configuration had:
DEFAULT_URL_PATTERN = ‘http://%s/mailman/’

shouldn’t that say “httpS:// …” ?

Andreas

On 06/24/2016 10:29 AM, John Griessen wrote:

The problem is with the moderation page. When submitting a change,
a security warning pops up saying info will not be encrypted

I found what this needed from Mark Sapiro:

put

DEFAULT_URL_PATTERN = ‘https://%s/mailman/’

in mm,_cfg.py ad then rerun

sudo /usr/sbin/withlist -l -r fix_url sandbox

On 06/24/2016 10:34 AM, A. Schulze wrote:

shouldn’t that say “httpS:// …” ?

Yes,

thanks,

JG

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs