Problem with libatk

I have installed ruby 1.8.5, the GTK+ win32 runtime 2.10.6 and Glade
Win32
3.0.2 from http://gladewin32.sourceforge.net, and ruby gtk 2.0.16 i386.

When I try to run one of the ruby gtk samples, it raises one error about
atk_text_free_ranges not found in library libatk-1.0-0.dll

I have checked the install path for libatk, its in the bin directory of
GTK,
and GTK is set in the PATH variable.

Does anyone have some clues?

PD: Yes, I know I should use linux (I do :-), but I’m looking for
something
that could produce code for both worlds.


Don’t just search. Find. Check out the new MSN Search!
http://search.msn.com/


Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net’s Techsay panel and you’ll get the chance to share
your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV

Hi,

On Mon, 08 Jan 2007 22:13:46 +0500
“Murmansk Manny” [email protected] wrote:

PD: Yes, I know I should use linux (I do :-), but I’m looking for something
that could produce code for both worlds.

Your libatk-1.0-0.dll seems old.

Try the latest gladewin32 devel package (not runtime).

I mean gladewin32 runtime may have a trouble with libatk.

Or get the newest libatk from the URL below.
http://ftp.gnome.org/pub/gnome/binaries/win32/

BTW, you shouldn’t ashame to use GTK2 with Win32.
If you have some troubles, ask here again.

Regards,
Masao


Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net’s Techsay panel and you’ll get the chance to share
your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs