Problem with gem or ruby 1.8.5 or fxruby or maybe 64bit?

Hi there.

Well i have a little problem. I just recently installed ruby 1.8.5 and
rubygems 0.9 and Fox 1.6.4 and fxruby 1.6.
For fxruby i installed the gem and that seems to work. As you can see
gemm list -local shows fxruby. But for some reason it wouldn´t
be found. if i use irb neither require ‘fox16’ nor require ‘rubygems’
require_gem ‘fxruby’ work.
Can somebody help me ?

Some more information ´bout my system.

I use linux slackware 10.2 and Suse 10.0 64 bit. It doesn´t work on both
systems.

Thanks

Marinho

gem list --local

*** LOCAL GEMS ***

fxruby (1.6.0)
FXRuby is the Ruby binding to the FOX GUI toolkit.

sources (0.0.1)
This package provides download sources for remote gem installation
root@wintermute:~# irb
irb(main):001:0> require ‘fox16’
LoadError: no such file to load – fox16
from (irb):1:in require' from (irb):1 irb(main):002:0> require 'rubygems' => true irb(main):003:0> require_gem 'fxruby' LoadError: no such file to load -- fox16 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:229:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:228:in each' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:228:inactivate’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:66:in
active_gem_with_options' from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:59:inrequire_gem’
from (irb):3
irb(main):004:0>

Marinho T. wrote:

Hi there.
Well i have a little problem. I just recently installed ruby 1.8.5 and
rubygems 0.9 and Fox 1.6.4 and fxruby 1.6.
For fxruby i installed the gem and that seems to work. As you can see
gemm list -local shows fxruby. But for some reason it wouldn´t be found.
if i use irb neither require ‘fox16’ nor require ‘rubygems’ require_gem
‘fxruby’ work. Can somebody help me ?

Your gem list shows that you don’t have any other gems installed. Have
you tried installing and using other gems?

Well pdf-writer gem seems to work. Maybe its a 64 bit problem. Fox
works, i tried the calculator. And fxruby did work AFTER installing it
from the sources AND after isntalling Ruby 1.8.4. Still it´s not a good
solution for me, i would prefer to install it from gem.

Joel VanderWerf schrieb:

On 9/4/06, Marinho T. [email protected] wrote:

Well pdf-writer gem seems to work. Maybe its a 64 bit problem. Fox
works, i tried the calculator. And fxruby did work AFTER installing it
from the sources AND after isntalling Ruby 1.8.4. Still it´s not a good
solution for me, i would prefer to install it from gem.

I don’t know if there is a binary gem distributed for FXRuby, but if
it is, it’s almost certainly only built for 32-bit Ruby.

-austin