Problem with foxGUIb


#1

Hi all,

I wrote this some days ago to the fxruby maillist throug ruby-forum,
but I didn’t get response yet.

IHi.

I’m learning Ruby, and I’m having a little problem.

Some days ago, I searched a GUI Builder to construct GUIs to my first
scripts, and founded foxGUIb.

In my Office (on a Windows XP 64bits box), I installed libGUIb without
troubles, and foxGUIb, was launched ok.

At home (Macbook), libGUIB, seems to be installed, but foxGUIb, gives me
this output when try to launch.

galilea:foxGUIb glpunzi$ ruby foxGUIb.rb
no such file to load – libGUIb16

Possible causes of this error are:

  • libGUIb is not installed
  • fxruby is not installed
  • fxruby gem could not be loaded because you did not start ruby with -
    rubygems option
  • other unexpected error. please check the following backtrace to find
    the cause of the error.

/Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in
gem_original_require' /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:inrequire’
foxGUIb.rb:11

I tried to install again libGUIb, but all seems ok.

galilea:libGUIb glpunzi$ sudo ruby install.rb
Password:
parsearg_config
install.rb: entering config phase…
—> lib
<— lib
install.rb: config done.
parsearg_setup
install.rb: entering setup phase…
—> lib
<— lib
install.rb: setup done.
parsearg_install
parsearg_install!!! ARGV:
install.rb: entering install phase…
—> lib
mkdir -p /
install libGUIb14.rb /
install libGUIb16.rb /
<— lib
install.rb: install done.

I tried to start fxri to see if was a problem with Fox, but started
fine.

galilea:foxGUIb glpunzi$ gem list fxruby

*** LOCAL GEMS ***

fxruby (1.6.16)

A friend, told me he as the same problem, but he wrote
require “rubygems”

at the first lines in the script and worked, but this don’t works for me

Some idea?

Thanks in advance.


#2

hi,
what do you get on irb when you do:

require “fox16”

?
– henon

On Tue, Nov 4, 2008 at 8:13 PM, Giuseppe Luigi Punzi Ruiz <


#3

Hi Meinrad.

galilea:~ glpunzi$ irb

require “fox16”
=> true

El 12/11/2008, a las 13:26, Meinrad R.
escribió:

hi,