Problem with displaying command line outputs

I am trying to run some tests, which utilize test::unit. Aside from the
typical assertions that generate dots, F/E and error messages, there are
some puts text that should be displayed too. This works fine when
running my test files (ie. test1.rb) one at a time from a command line.

However, when I run multiple tests in the same directory from one file,
which is either another .rb file that just runs each test one after
another through the ruby command, or optionally, I have set up a rake
file that iterates through everything, I get no output on the command
line. The tests do run for sure, but I would like to see all the output
as if I were running each test individually. Is there a way to force the
output to display?

Thanks in advance!

I tried a few more approaches, but they don’t work either. I have an .rb
file that just requires all the other .rb files, but the problem is, I
can’t run tests by passing command line arguments that way.
Any suggestions? Thanks again!

hi john -

don’t know if this will work in your case, but i’ve found when doing
similar tests/debugs that “p string” works when “puts string” doesn’t.
“p” calls obj.inspect, rather than obj.to_s -
http://polishinggems.blogspot.com/2011/02/p-vs-puts-vs-print.html

  • j

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs