Problem with deploying (can't activate rails)

Hi all,

I have a problem with deploying rails via capistrano. (updated
capistrano)

*** [err :: www.teamgeisthq.com] /usr/local/lib/site_ruby/1.8/
rubygems.rb:149:in activate' *** [err :: www.teamgeisthq.com] : *** [err :: www.teamgeisthq.com] can't activate rails (= 2.2.2, runtime), already activated rails-2.3.2 *** [err :: www.teamgeisthq.com] ( *** [err :: www.teamgeisthq.com] Gem::Exception *** [err :: www.teamgeisthq.com] ) *** [err :: www.teamgeisthq.com] from /usr/local/lib/site_ruby/1.8/ rubygems/custom_require.rb:35:inrequire’
*** [err :: www.teamgeisthq.com] from /home/myusername/www.testt.com/
current/script/process/reaper:3

I understand that the spawner is no part anymore of rails 2.3 and
installed irs_process_scripts in my vendor/plugins dir.

Still I get this error.

Someone knows how to solve this?

Thanks

Tarscher wrote:

Hi all,

I have a problem with deploying rails via capistrano. (updated
capistrano)

*** [err :: www.teamgeisthq.com] /usr/local/lib/site_ruby/1.8/
rubygems.rb:149:in activate' *** [err :: www.teamgeisthq.com] : *** [err :: www.teamgeisthq.com] can't activate rails (= 2.2.2, runtime), already activated rails-2.3.2 *** [err :: www.teamgeisthq.com] ( *** [err :: www.teamgeisthq.com] Gem::Exception *** [err :: www.teamgeisthq.com] ) *** [err :: www.teamgeisthq.com] from /usr/local/lib/site_ruby/1.8/ rubygems/custom_require.rb:35:inrequire’
*** [err :: www.teamgeisthq.com] from /home/myusername/www.testt.com/
current/script/process/reaper:3

I understand that the spawner is no part anymore of rails 2.3 and
installed irs_process_scripts in my vendor/plugins dir.

Still I get this error.

Someone knows how to solve this?

Thanks

One of your plugins has a requirement to use rails 2.2.2… probably
irs_process_scripts??..

merely go into the plugins directory, then into the specific plugin and
change the dependency requirement from = 2.2.2 to >= 2.2.2

Alternatively, you can check if the plugin has been updated to work with
2.3

Make sure you test the plugin thoroughly…

hth

ilan