Problem with db:create

When I do the command:

db:create:all

I got this error:

rake aborted!
Please install the jdbcpostgresql adapter: gem install activerecord-jdbcpostgresql-adapter (no such file to load – java)

I have ruby-dev installed, also pg gem.

When I do the comand “$ dpkg -l | grep ruby” i got this:

ii jruby1.1 1.1.6-3
100% pure-Java implementation of Ruby
ii libaugeas-ruby1.8 0.2.0-2ubuntu3
Augeas bindings for the Ruby language
ii libbreakpoint-ruby1.8 0.5.1-2
Ruby library for adding breakpoints to Ruby
ii libbuilder-ruby 2.1.2-2
Ruby library to facilitate programatic gener
ii libbuilder-ruby1.8 2.1.2-2
Ruby library to facilitate programatic gener
ii libcmdparse2-ruby1.8 2.0.2-2
Advanced command line parsing module support
ii libdaemons-ruby1.8 1.0.10-2
Ruby daemons library
ii libdbm-ruby 4.2
DBM interface for Ruby
ii libdbm-ruby1.8 1.8.7.249-2
DBM interface for Ruby 1.8
ii libdbm-ruby1.9.1 1.9.1.378-1
DBM interface for Ruby 1.9.1
ii liberb-ruby 4.2
transitional dummy package
ii libgdbm-ruby 4.2
GDBM interface for Ruby
ii libgdbm-ruby1.8 1.8.7.249-2
GDBM interface for Ruby 1.8
ii libgdbm-ruby1.9.1 1.9.1.378-1
GDBM interface for Ruby 1.9.1
ii liblog4r-ruby1.8 1.0.5-8
A logging library for Ruby
ii libmmap-ruby1.8 0.2.6-3
Ruby interface to manage memory-mapped file
ii libmocha-ruby 0.9.8-1
Mocking and stubbing library for Ruby
ii libmocha-ruby1.8 0.9.8-1
Mocking and stubbing library for Ruby 1.8
ii libncurses-ruby1.8 1.2.4-2
ruby Extension for the ncurses C library
ii libopenssl-ruby 4.2
OpenSSL interface for Ruby
ii libopenssl-ruby1.8 1.8.7.249-2
OpenSSL interface for Ruby 1.8
ii libopenssl-ruby1.9.1 1.9.1.378-1
OpenSSL interface for Ruby 1.9.1
ii libpgsql-ruby 0.8.0-1.1
PostgreSQL interface for Ruby
ii libpgsql-ruby1.8 0.8.0-1.1
PostgreSQL interface for Ruby 1.8
ii libpgsql-ruby1.9.1 0.8.0-1.1
PostgreSQL interface for Ruby 1.9.1
ii libreadline-ruby 4.2
Readline interface for Ruby
ii libreadline-ruby1.8 1.8.7.249-2
Readline interface for Ruby 1.8
ii libreadline-ruby1.9.1 1.9.1.378-1
Readline interface for Ruby 1.9.1
ii libredcloth-ruby 4.2.2-1.1
Textile module for Ruby
ii libredcloth-ruby1.8 4.2.2-1.1
Textile module for Ruby 1.8
ii librrd-ruby1.8 1.3.8-1ubuntu1
Time-series data storage and display system
ii libruby 4.2
Libraries necessary to run Ruby 1.8.x
ii libruby1.8 1.8.7.249-2
Libraries necessary to run Ruby 1.8
ii libruby1.8-dbg 1.8.7.249-2
Debugging symbols for Ruby 1.8
ii libruby1.8-extras 0.5
a bundle of additional libraries for Ruby 1.
ii libruby1.9.1 1.9.1.378-1
Libraries necessary to run Ruby 1.9.1
ii libruby1.9.1-dbg 1.9.1.378-1
Debugging symbols for Ruby 1.9.1
ii libshadow-ruby1.8 1.4.1-8build1
Interface of shadow password for Ruby 1.8
ii libsqlite3-ruby 1.2.4-2.1
SQLite3 interface for Ruby
ii libsqlite3-ruby1.8 1.2.4-2.1
SQLite3 interface for Ruby 1.8
ii libtcltk-ruby 4.2
Tcl/Tk interface for Ruby
ii libtcltk-ruby1.8 1.8.7.249-2
Tcl/Tk interface for Ruby 1.8
ii libtcltk-ruby1.9.1 1.9.1.378-1
Tcl/Tk interface for Ruby 1.9.1
ii libxml-simple-ruby 1.0.12-1
Simple Ruby API for reading and writing XML
ii rails 2.2.3-2
MVC ruby based framework geared for web appl
ii rake 0.8.7-1
a ruby build program
ii rdoc 4.2
Generate documentation from ruby source file
ii ruby 4.2
An interpreter of object-oriented scripting
ii ruby-dev 4.2
Header files for compiling extension modules
ii ruby-elisp 4.2
Emacs-lisp ruby-mode for Ruby
ii ruby-full 4.2
Ruby full installation
ii ruby1.8 1.8.7.249-2
Interpreter of object-oriented scripting lan
ii ruby1.8-dev 1.8.7.249-2
Header files for compiling extension modules
ii ruby1.8-elisp 1.8.7.249-2
ruby-mode for Emacsen
ii ruby1.9.1 1.9.1.378-1
Interpreter of object-oriented scripting lan
ii ruby1.9.1-dev 1.9.1.378-1
Header files for compiling extension modules
ii ruby1.9.1-examples 1.9.1.378-1
Examples for Ruby 1.9
ii ruby1.9.1-full 1.9.1.378-1
Ruby 1.9.1 full installation
ii rubygems 1.3.5-1ubuntu2
package management framework for Ruby librar
ii rubygems1.8 1.3.5-1ubuntu2
package management framework for Ruby librar
ii rubygems1.9.1 1.3.5-1ubuntu2
package management framework for Ruby librar

Am I missing something?

Solved.

just change my database to: adapter: postgresql
It was adapter: jdbcpostgresql

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs