Problem with database.yml

Hi all! I am completely new to RoR and I have runned into a problem. I
have followed an online course for RoR on Lynda.com and everything has
worked out well until I should change to database.yml file.

Instead of the tutors text “host: localhost” I get “socket: /tmp/
mysql.sock” in development enviroment

I thought I would give it a try to continue anyway but when I later
try to do “rake db:migrate” after activating my webserver, I get this
error:

rake aborted!
syntax error on line 18, col 2: ` host: localhost’

(See full trace by running task with --trace)

Any help would be gladely appreciated :slight_smile:

Thanks in advance,

Jacob

Jacob wrote:

Hi all! I am completely new to RoR and I have runned into a problem. I
have followed an online course for RoR on Lynda.com and everything has
worked out well until I should change to database.yml file.

Instead of the tutors text “host: localhost” I get “socket: /tmp/
mysql.sock” in development enviroment

my database.yml looks like this:
host: localhost
db…
user…
passwd…
adapter…
socket:

host is a must, socket is an option. the socket describes the path to
your database connection. in ubuntu its /var/run/mysqld/mysqld.sock

benni

Thanks for your reply. I might add that I use mac os x…

How should I do to make it work?

On 3 Okt, 10:36, Benjamin M. [email protected]

Jacob wrote:

Thanks for your reply. I might add that I use mac os x…

How should I do to make it work?

mac os x is standard in rails-development, isn’t it?
try to comment out the socket-line:

socket: …

Thanks for your response Benjamin.

I am sorry but I am too much of a beginner to see what you mean by
commenting out of the socket-line… I guess that you have to bring it
down to a 3 year olds level :slight_smile:

On 3 Okt, 11:41, Benjamin M. [email protected]

I identified the problem.

instead of spaces there were tabs before the lines. Kind of strange
since that file is generated by the system…

rake db:migrate still doesn´t work, now it tells me that “#28000Access
denied for user ‘root’@‘localhost’ (using password: NO)”

but at least it´s one step in the right direction :slight_smile:

On 3 Oct 2007, at 11:13, Jacob wrote:

Thanks for your response Benjamin.

I am sorry but I am too much of a beginner to see what you mean by
commenting out of the socket-line… I guess that you have to bring it
down to a 3 year olds level :slight_smile:
Comment out: place a # symbol at the start of the line.
It’s also worth checking that you’ve indented with spaces not tabs -
yaml doesn’t like tabs

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs