Problem with Apache 2 and eRubis/eRuby


I’m currently trying to set up ruby for serving web pages on my Debian
Everything from ruby over eRuby/eRubis to mysql works fine in the shell,
but when it came to Apache2 there was nothing but problems. I solved
much of them, but now Apache2 seems to call the eRuby/eRubis File (tried
both) not right because this error appears on accessing the file over
the browser:

Not Found

The requested URL /cgi-bin/eruby/test.rb was not found on this server.

Content of httpd.conf:
AddType application/x-httpd-eruby .rb
Action application/x-httpd-eruby /cgi-bin/eruby

<% puts “Test” %>

eRuby and eRubis are in the /cgi-bin/, all of them (dir+files) are set
to 775, should not be the problem. Could somebody help me? Already
googled for hours but nothing worked for me :frowning:

Rudolf H. a écrit :

Not Found

eRuby and eRubis are in the /cgi-bin/, all of them (dir+files) are set

Do you really mean /cgi-bin/ ? I think apache want it in
Maybe you can try a thing like :
sudo ln -s which eruby /usr/lib/cgi-bin/eruby