Problem with Amrita

Hi all

I’m a ruby newbie and I’m trying to do something with templates using
Amrita.

I have a template which contains html with some


into it and Amrita doesn’t generate this chunk of html because it gets
because there is no something data into the structure.

Do you know if there is a way to jump over this problem?

Do you think Amrita is not good enough and you can tell me something
better?

Thanks in advance

Kind regards

Miquel (a.k.a. Ton)
Linux User #286784
GPG Key : 4D91EF7F
Debian GNU/Linux (Linux Wolverine 2.6.14)

Welcome to the jungle, we got fun and games
Guns n’ Roses


LLama Gratis a cualquier PC del Mundo.
Llamadas a fijos y móviles desde 1 céntimo por minuto.
http://es.voice.yahoo.com

Miquel O. wrote:

I have a template which contains html with some


into it and Amrita doesn’t generate this chunk of html because it gets
because there is no something data into the structure.

Do you know if there is a way to jump over this problem?

It’s been a while, but I’m pretty sure you can get Amrita to use
something other than “id” as its anchor. It seems a bit silly to me to
use “id” for two unconnected things.

Do you think Amrita is not good enough and you can tell me something better?

Amrita’s fine. There are other options that will probably be faster or
may appeal to you (in terms of the way they do things) but Amrita can
get the job done elegantly.

Cheers,
Gavin

On Sun, 29 Oct 2006 00:35:12 +0900
Gavin S. wrote:

use “id” for two unconnected things.
Are you telling me that I can use another “keyword” different than id
to tell Amrita where it must change when I call the expand method?How
can I do this?

Miquel (a.k.a. Ton)
Linux User #286784
GPG Key : 4D91EF7F
Debian GNU/Linux (Linux Wolverine 2.6.14)

Welcome to the jungle, we got fun and games
Guns n’ Roses


LLama Gratis a cualquier PC del Mundo.
Llamadas a fijos y móviles desde 1 céntimo por minuto.
http://es.voice.yahoo.com

On 10/28/06, Miquel O. [email protected] wrote:

Hi all

I’m a ruby newbie and I’m trying to do something with templates using
Amrita.

I have a template which contains html with some …
into it and Amrita doesn’t generate this chunk of html because it gets
because there is no something data into the structure.

Do you know if there is a way to jump over this problem?

I’m not sure exactly what your problem is but the best place to ask an
Amrita question would be on their mailing list which you can subscribe
to
from here
http://amrita2.rubyforge.org/

You would have the most knowlegable Amrita folks to discuss things with
there.

Do you think Amrita is not good enough and you can tell me something
better?

Amrita and Amrita2 is a fine project. The main developer, Taku Nakajima
is,
a dedicated person. So if the project meets your needs then it should be
a
solid choice.

If you want to look at some additional templating projects that might
also
work for you, check out

MasterView Template Engine
http://masterview.org/
ht
http://rubyforge.org/projects/masterviewtp://rubyforge.org/projects/mashttp://rubyforge.org/projects/masterview
terview http://rubyforge.org/projects/masterview
(This is the project that Deb Lewis and I are developing)
It has some slightly different goals and features. There are some videos
and
screenshots on the site to explain. We have several mailing lists as
well,
so you can post to our masterview-users mailing list if you have
additional
questions.

Kwartz template engine
http://www.kuwata-lab.co
http://www.kuwata-lab.com/kwartz/m/kwartz/http://www.kuwata-lab.com/kwartz/

Liquid template engine
http://home.leetsoft.com
http://home.leetsoft.com/liquid/liquidhttp://home.leetsoft.com/liquid

Hope this helps. I’d be glad to help further if I can.

Blessings,

Jeff B.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs