Problem with AJAX not working on IE


#1

I’m having a problem making this code to work on IE:

var Permit = {
// Expand permit information
onMore: function(id) {
new Ajax.Updater(‘pm-’+id+’-lg’, ‘/employees/sign_permit_lg/’+id,
{asynchronous:true, evalScripts:true,
onLoading:function(request){ General.onSpinnerOn(‘pm-’+id+’-sm’)
},
onComplete:function(request){
General.onSpinnerOff(‘pm-’+id+’-sm’);
Element.hide(‘pm-’+id+’-sm’);
Effect.Appear(‘pm-’+id+’-lg’);
} } );
}
}

This code works just fine on Firefox 1.5 but goes nowhere on IE. The
General.onSpinnerOn/Off functions show show/hide a div that has the
spinning
ball thingy. Has anybody encountered a problem when trying to run an
Ajax.Updater that never comes back in IE but has no problem on
Firefox/Mozilla?

Any help would be greatly appreciated,


#2

Picking up an old thread…

I have the same problem, where a simple link_to_remote works fine in
Safari and Firefox, but doesn’t update the page in IE. The request is
sent to the server though, the returned partial just never shows up in
IE. No script errors or anything.

Has anyone else seen this? Any ideas how to fix it?


#3

This may not be the same problem you’re having, but I’ve noticed that IE
doesn’t like to do fancy things with anything but div and span tags. I
was trying to :update tables and some other tags, and it just wouldn’t
work. It worked fine on Safari and Firefox.

Carl-Johan K. wrote:

Picking up an old thread…

I have the same problem, where a simple link_to_remote works fine in
Safari and Firefox, but doesn’t update the page in IE. The request is
sent to the server though, the returned partial just never shows up in
IE. No script errors or anything.

Has anyone else seen this? Any ideas how to fix it?