Problem witch fastcgi conettions

Hi list, sorry my english.

I use this tutorial:

and the 9000 port is open:

[email protected]:/etc/init.d# nmap localhost

Starting Nmap 4.76 ( http://nmap.org ) at 2010-04-01 12:44 CDT
Warning: Hostname localhost resolves to 2 IPs. Using 127.0.0.1.
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 995 closed ports
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
631/tcp open ipp
9000/tcp open unknown

in /etc/nginx/site-enable/defalut, I have that:

server {
listen 80;
server_name localhost;

    access_log  /var/log/nginx/localhost.access.log;

    location / {
            root   /var/www/nginx-default;
            index  index.html index.htm;
    }

    location /doc {
            root   /usr/share;
            autoindex on;
            allow 127.0.0.1;
            deny all;
    }

    location /images {
            root   /usr/share;
            autoindex on;
    }

    # La Web de la SCJM
    location /SCJM {
            root /home/michelvf;
            index index.php;
    }


    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
            root   /var/www/nginx-default;
    }

location ~ .php$ {
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
/scripts$fastcgi_script_name;
include fastcgi_params;
}

}

And in the browser, show that:
No input file specified.

And the log show that:
2010/04/01 12:21:19 [error] 6196#0: *1 connect() failed (111: Connection
refused) while connecting to upstream, client: 127.0.0.1, server:
localhost, request: “GET /scjm/index.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “localhost”
2010/04/01 12:24:00 [error] 6196#0: *6 connect() failed (111: Connection
refused) while connecting to upstream, client: 127.0.0.1, server:
localhost, request: “GET /scjm/index.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “localhost”

Why the browser don’t can show de index.php.

Thank to all.


Usemos el Software Libre “Con todos y para el bien de todos”
José Martí, 26 de noviembre de 1891, Tampa.

Lic. Michel Vega Fuenzalida. Usuario Linux: 353763
Coordinador del Grupo Linux Pinero
Administrador de Red
Hospital General Docente “Héroes de Baire”,
Nueva Gerona, Isla de la Juventud, Cuba.

Teléfono: +53 46 323012.

Este mensaje le ha llegado mediante el servicio de correo electronico
que ofrece Infomed para respaldar el cumplimiento de las misiones del
Sistema Nacional de Salud. La persona que envia este correo asume el
compromiso de usar el servicio a tales fines y cumplir con las
regulaciones establecidas

Infomed: http://www.sld.cu/

On Thu, 2010-04-01 at 12:55 -0400, Michel Vega Fuenzalida wrote:

in /etc/nginx/site-enable/defalut, I have that:
}
autoindex on;
location = /50x.html {
root /var/www/nginx-default;
}

location ~ .php$ {
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
/scripts$fastcgi_script_name;

I expect that this line (SCRIPT_FILENAME) is the source of your
problems. Verify that your URI resolves to this path.

Your URI is /scjm/index.php, and your root is /home/michelvf, so I’m
guessing your index.php lies at /home/michelvf/scjm/index.php or maybe
at /home/michelvf/scjm/scripts/index.php? In either case, your
SCRIPT_FILENAME is most likely incorrect. SCRIPT_FILENAME is a
filesystem path, not a URI, so something like $document_root
$fastcgi_script_name or $document_root/scripts/$fastcgi_script_name
would be seem more appropriate.

            include fastcgi_params;
    }

}

And in the browser, show that:
No input file specified.

“No input file specified” is a PHP message. Nginx is successfully
connecting to PHP, so the error log below is unrelated (probably left
over from earlier errors that you already corrected).

And the log show that:
2010/04/01 12:21:19 [error] 6196#0: *1 connect() failed (111: Connection
refused) while connecting to upstream, client: 127.0.0.1, server:
localhost, request: “GET /scjm/index.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “localhost”
2010/04/01 12:24:00 [error] 6196#0: *6 connect() failed (111: Connection
refused) while connecting to upstream, client: 127.0.0.1, server:
localhost, request: “GET /scjm/index.php HTTP/1.1”, upstream:
“fastcgi://127.0.0.1:9000”, host: “localhost”

Regards,
Cliff

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs