Problem when installing latest rails


ruby 1.9.2p136 (2010-12-25) [i386-mingw32]
windows7 64 bit
gem 1.3.7

while I issue “gem install rails” command, I got the output
ERROR: Error installing rails:
rails requires activesupport (<= 3.0.3, runtime)

it’s a problem that shouldn’t happen.
anyone know the answer?



Check if you have installed Ruby Gems. If not do it from the site: Run the setup.rb file once you
extract that package. To install other gems you need to see whether
you have install Ruby Gems first.

In case you have you have certain dependent gems which you need to
install first may be. For gems refer to the site:
.As in your case you would require to install a version of
activesupport gem , version less than or equal 3.0.3. You also need to
search for and install a gem by the name ‘runtime’ from the same site
of ruby gems. Once you install these gems, then try installing Rails…
It should work…