Problem using net/ftp om SunOS 5.8 - libgcc_s.so.1 not found


#1

When the script gets to require “net/ftp” I get the following error:

/usr/local/lib/ruby/1.8/sparc-solaris2.8/socket.so: ld.so.1:
compress_n_ftp.rb: fatal: libgcc_s.so.1: open failed: No such file or
directory - /usr/local/lib/ruby/1.8/sparc-solaris2.8/socket.so
(LoadError)
from /usr/local/lib/ruby/1.8/net/ftp.rb:17
from ./compress_n_ftp.rb:9:in `require’
from ./compress_n_ftp.rb:9

Any Idea how to fix this?

Regards,
Ben