Problem upgrading to rails 1.1 on Unix

Hi,

I’m having problems installing rails on our Unix server.

“gem install rails --include-dependencies” only install rails 1.0.0
“gem update rails” updates to rails 1.0.0

I have installed rails on my windows box (i forgot how!).
Running “gem -list --local” on my windows box gives me:

rails (1.0.0.4008,…

Yet when i run :

gem -list --remote

there is no mention of “rails (1.0.0.4008,” , only rails 1.0.0

What am i missing? I need to install rails 1.1 on the unix box

Any help would be greately appreciated as i’m trying to deploy today

this is the error i recieve :

/opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:256:in
send': undefined methoddebug_rjs=’ for ActionView::Base:Class
(NoMethodError)
from
/opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:256:in
initialize_framework_settings' from /opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:255:ininitialize_framework_settings’
from
/opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:252:in
initialize_framework_settings' from /opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:91:inprocess’
from
/opt/tools/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:42:in
run' from ./config/environment.rb:14 from /opt/tools/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/opt/tools/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
require' from /opt/tools/lib/ruby/gems/1.8/gems/mongrel-0.3.9/bin/mongrel_rails:76:inconfigure_rails’
from
/opt/tools/lib/ruby/gems/1.8/gems/mongrel-0.3.9/bin/mongrel_rails:131:in
run' from /opt/tools/lib/ruby/gems/1.8/gems/mongrel-0.3.9/lib/mongrel/command.rb:162:inrun’
from
/opt/tools/lib/ruby/gems/1.8/gems/mongrel-0.3.9/bin/mongrel_rails:220
from /opt/tools/bin/mongrel_rails:18

I’m having problems installing rails on our Unix server.

“gem install rails --include-dependencies” only install rails 1.0.0
“gem update rails” updates to rails 1.0.0

Is ruby and gems installed on the unix-box? What flavor of unix is it?
You may have to be a priviliged user, either using sudo or su.

I have installed rails on my windows box (i forgot how!).
Running “gem -list --local” on my windows box gives me:

Is this a separate problem upgrading to rails 1.1?

regards
Claus

“gem install rails --include-dependencies” only install rails 1.0.0
“gem update rails” updates to rails 1.0.0

Is ruby and gems installed on the unix-box? What flavor of unix is it?
You may have to be a priviliged user, either using sudo or su.

Im logged in as root. It’s solaris. Gems and ruby are installed, the
latest version

I’ve used putty to SSH in :
Here is what happens:

gem install rails -include-dependencies -p http://saiproxy:3128

Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Successfully installed rails-1.0.0

So it seems to install correctly. But not rails 1.1!! whats going on?

Im logged in as root. It’s solaris. Gems and ruby are installed, the
latest version

Have you telnet’ed or ssh’ed to the solaris-box when you do ‘gem list’?

regards
Claus

I’d try and update gems itself if it an older version.
http://docs.rubygems.org/read/chapter/3#page14
-bakki

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs