Problem upgrading app to RoR1.1


#1

Hi,
I need some help when upgrading one aplication made on rails1.0 to
rails1.1

I have the application on a debian sarge i upgrade ruby gems to 1.1 and
ruby to 1.84 and make an freeze on proyect folder, but when i try to run
the application in production mode gave me these errors:

[Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45]
file
/home/siniestros/beta0.2/public/…/config/…/tmp/sessions//ruby_sess.de090bb98c8cb354
not readable\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45] /usr/lib/ruby/1.8/pstore.rb:95:in initialize'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/1.8/cgi/session/pstore.rb:70:ininitialize’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45] /usr/lib/ruby/1.8/cgi/session.rb:273:in initialize'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/cgi_process.rb:111:insession’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45]
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/cgi_process.rb:141:in
stale_session_check!'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/cgi_process.rb:107:insession’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45]
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/base.rb:887:in
assign_shortcuts_without_flash'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/flash.rb:141:inassign_shortcuts’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45]
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/base.rb:375:in
process_without_filters'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/filters.rb:377:inprocess_without_session_management_support’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45]
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0.4168/lib/action_controller/session_management.rb:117:in
process'\r [Wed Apr 05 13:49:09 2006] [error] [client 99.5.0.45] /usr/lib/ruby/gems/1.8/gems/rails-1.1.0.4168/lib/dispatcher.rb:38:indispatch’\r
[Wed Apr 05 13:49:09 2006] [error] [client
99.5.0.45] /home/siniestros/beta0.2/public/dispatch.cgi:10

when i run it in development mode everything its ok.

anyone could give me some help?

thanks a lot