Problem setting up certificate

I’m getting this error after installing the certificate & key:

[emerg] 809#0:
SSL_CTX_use_PrivateKey_file(“/paging/site/config/server.key”) failed
(SSL: error:0B080074:x509 certificate
routines:X509_check_private_key:key values mismatch)

I’ve tried this twice, (started over with a new csr, thinking I had
screwed up and used the wrong key or something), and am still getting
the error. I’ve double-checked to make sure that nginx is using the
config file I expect, and that it specifies the correct locations for
the cert & key.

How should I proceed in trouble-shooting this?


Scott R.
[email protected]
http://www.elevated-dev.com/
(303) 722-0567 voice

Meh, never mind. Supposedly same source of certificates as prior server
installed within this same institution (I didn’t do the prior one), but
this one is in root->mine order instead of mine->root order. Edited the
cert file to switch them around, and now it works.

On May 31, 2013, at 12:40 PM, Scott R. wrote:

[email protected]


Scott R.
[email protected]
http://www.elevated-dev.com/
(303) 722-0567 voice