Problem: segfault in ruby with fastcgi

i’m trying to get fastcgi to work on solaris. my rails application works
fine with normal cgi, but with fastcgi i always get a segmentationfault.
the app runs normally with fastcgi under linux but that doesnt really
help :slight_smile:

tested systems:
uname -a
SunOS … 5.10 Generic_118833-17 sun4v sparc SUNW,Sun-Fire-T200
SunOS … 5.10 Generic sun4u sparc SUNW,Sun-Blade-100
SunOS … 5.10 Generic sun4u sparc SUNW,Sun-Fire-280R

i’ve tried several rubyversions with the same error (1.8.x), some
selfcompiled with sun-compiler or gcc, some precompiled (blastwave).
as httpserver i aim for apache 1.3 (included in oracle applicationserver
with mod_fastcgi), but tried apache 2.2 as well (with mod_fcgid,
i followed several instructions on the net, eg

i’ve also tried a simple test-application to rule out a problem in the
rails application.

the actual errormessage looks like this:
/usr/local/lib/ruby/1.8/timeout.rb:52: [BUG] Segmentation fault
ruby 1.8.5 (2007-03-13) [sparc-solaris2.10]

[Mon Mar 19 08:41:58 2007] [error] [client] [ecid:
1174290116:,0] FastCGI: incomplete headers (0 by
tes) received from server “/public/dispatch.fcgi”
[Mon Mar 19 08:41:58 2007] [warn] FastCGI: (dynamic) server
“/public/dispatch.fcgi” (pid 22852) terminated due
to uncaught signal ‘6’ (Abort), a core file may have been generated

the line in timeout.rb is Thread.start.
at some times (other versions of ruby, gems etc…) i’ve got a
segmentationfault in another rubyclass, also at a line with Thread.start

what else should i try? or does it look like a bug in ruby? i don’t
really have the know-how to debug the coredump but if you think it to be
rewarding, maybe i should consider trying…

gem query
*** LOCAL GEMS ***

actionmailer (1.3.3)
Service layer for easy email delivery and testing.

actionpack (1.13.3)
Web-flow and rendering framework putting the VC in MVC.

actionwebservice (1.2.3)
Web service support for Action Pack.

activerecord (1.15.3)
Implements the ActiveRecord pattern for ORM.

activesupport (1.4.2)
Support and utility classes used by the Rails framework.

fcgi (0.8.7)
FastCGI library for Ruby.

rails (1.2.3)
Web-application framework with template engine, control-flow layer,
and ORM.

rake (0.7.2)
Ruby based make-like utility.

soap4r (
An implementation of SOAP 1.1 for Ruby.

sources (0.0.1)
This package provides download sources for remote gem installation

thanks, cornelius