Problem running phusion passenger on os x 10.6

Hi,
I am trying to update passenger for 10.6, and I am getting an error
relating to fastthread… passenger thinks fastthread is missing.
Here’ the apache error log output:


/usr/local/lib/ruby/site_ruby/1.8/i686-darwin8.10.1/
fastthread.bundle:
Failed to load /usr/local/lib/ruby/site_ruby/1.8/i686-darwin8.10.1/
fastthread.bundle (LoadError)
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:
31:in require' from /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/ phusion_passenger/utils.rb:28 from /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/bin/ passenger- spawn-server:53:inrequire’
from /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/bin/
passenger-
spawn-server:53
[ pid=68789 file=ext/apache2/Hooks.cpp:725 time=2009-09-04
11:26:57.935 ]:
Unexpected error in mod_passenger: Cannot spawn application ‘/
Users/
sohara/Sites/constellation’: The spawn server has exited
unexpectedly.
Backtrace:
in ‘virtual boost::shared_ptrPassenger::Application::Session
Passenger::ApplicationPoolServer::Client::get(const
Passenger::PoolOptions&)’ (ApplicationPoolServer.h:471)
in ‘int Hooks::handleRequest(request_rec*)’ (Hooks.cpp:521)


I installed fastthread threw ruby gems and didn’t get any errors
aside
from some ri and rdoc errors (missing variables).
I then installed it from the tar package available on rubyforge. But
I still get the following error when I tried to reinstall the
passenger apache module:

  • fastthread… not found
    Does anyone know where passenger is looking for the fastthread
    bundle?
    I made symbolic links to it in /usr/bin and /usr/sbin, just in case,
    but that didn’t help. Currently my install of fastthread is at /usr/
    local/lib/ruby/site_ruby/1.8/i686-darwin8.10.1/fastthread.bundle
    Thanks in advance for any ideas.
    Sean

On Fri, Sep 4, 2009 at 2:43 PM, [email protected]
<[email protected]

wrote:

   from /usr/local/lib/ruby/site_ruby/1.8/rubygems/

[ pid=68789 file=ext/apache2/Hooks.cpp:725 time=2009-09-04


but that didn’t help. Currently my install of fastthread is at /usr/
local/lib/ruby/site_ruby/1.8/i686-darwin8.10.1/fastthread.bundle
Thanks in advance for any ideas.
Sean

Hi, did you rebuild all native gems after installing Snow Leopard and
their associated development tools? If not, then you should read the
following:

http://weblog.rubyonrails.org/2009/8/30/upgrading-to-snow-leopard

BTW, I have been using Snow Leopard and Passenger without any
issues.

Good luck,

-Conrad

Thanks for the idea. I had already updated everything. The problem
turned out to be that for some reason, my installation of ruby was
still at 1.8.6 instead of 1.8.7 that is supposed to be installed with
snow leopard. in my case it wasn’t, not sure why, but the passenger
install script only requires the fastthread library in ruby versions
lower than 1.8.7. So I installed ruby 1.8.7 from source, and now
everything seems to be working.

thanks,
sean

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs