Problem on transmitting signal

Hi all,

I’m transmitting a packet to 2.4G band using RFX2400 on USRP1 and
observed
this problem:
Once in a while, the transmission stops in the middle of the packet
being
transmitted.

Does anyone know if 1) there is any TX amp control line which is
controlled by the FPGA and in what condition it toggles,
2) if it can happen when USRP underrun (uU) occurs
3) if there is a schematic for RFX2400 and usrp1 available?

I’m using gnuradio 3.2.2.
Thanks,

Thomas

On 08/04/2011 10:30 AM, Thomas H Kim wrote:

Hi all,

I’m transmitting a packet to 2.4G band using RFX2400 on USRP1 and
observed this problem:
Once in a while, the transmission stops in the middle of the packet
being transmitted.

Does anyone know if 1) there is any TX amp control line which is
controlled by the FPGA and in what condition it toggles,
Any transmit power control will be under control of the software–the
FPGA doesn’t make spontaneous decisions about that.

  1. if it can happen when USRP underrun (uU) occurs
    When the host-side underruns the transmitter, it must necessarily
    transmit 0s, which effectively turns off the transmitter for the
    duration of the underrun.
  1. if there is a schematic for RFX2400 and usrp1 available?
    Schematics available here:

http://code.ettus.com/redmine/ettus/projects/public/documents

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs