[problem] mongrel_cluster and rack 1.0.1

Hi !

I’m trying to run redmine 0.9.2 (it requires rack 1.0.1) with a
mongrel_cluster.

If I run ruby script/server webrick -e production -p 3000, everything is
ok, redmine runs.

But if I try with mongrel with appropriate conf (mongrel_cluster.yml is
a link to /etc/mongrel_cluster/redmine.yml), I run into some problems :

$cat /etc/mongrel_cluster/redmine.yml

group: nginx
user: mongrel
log_file: /var/log/mongrel.log
address: 127.0.0.1
port: “8000”
cwd: /var/www/redmine
environment: production
pid_file: /home/mongrel/pids/mongrel.pid
servers: 2

$mongrel_cluster_ctl start -c /etc/mongrel_cluster -v
Starting all mongrel_clusters…
mongrel_rails cluster::start -C redmine.yml -v
starting port 8000
mongrel_rails start -d -e production -a 127.0.0.1 -c /var/www/redmine
–user mongrel --group nginx -p 8000 -P
/home/mongrel/pids/mongrel.8000.pid -l /var/log/mongrel.8000.log
starting port 8001
mongrel_rails start -d -e production -a 127.0.0.1 -c /var/www/redmine
–user mongrel --group nginx -p 8001 -P
/home/mongrel/pids/mongrel.8001.pid -l /var/log/mongrel.8001.log

$mongrel_cluster_ctl status
Checking all mongrel_clusters…
mongrel_rails cluster::status -C redmine.yml
missing pid_file: /home/mongrel/pids/mongrel.8000.pid
missing mongrel_rails: port 8000

missing pid_file: /home/mongrel/pids/mongrel.8001.pid
missing mongrel_rails: port 8001
$cat /var/log/mongrel.8000.log

* Daemonized, any open files are closed. Look at

/home/mongrel/pids/mongrel.8000.pid and /var/log/mongrel.8000.log for
info.
* Starting Mongrel listening at 127.0.0.1:8000
* Initiating groups for “mongrel”:“nginx”.
* Changing group to “nginx”.
* Changing user to “mongrel”.
* Starting Rails with production environment…
/var/www/redmine/config/…/vendor/rails/railties/lib/initializer.rb:271:in
require_frameworks': can't activate rack (= 1.0.0, runtime) for [], already activated rack-1.0.1 for [] (RuntimeError) from /var/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:134:inprocess’
from
/var/www/redmine/config/…/vendor/rails/railties/lib/initializer.rb:113:in
send' from /var/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:inrun’
from /var/www/redmine/config/environment.rb:20
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/…/lib/mongrel/rails.rb:147:in
rails' from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:113:incloaker_’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/…/lib/mongrel/configurator.rb:149:in
call' from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:inlistener’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:99:in
cloaker_' from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:incall’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/…/lib/mongrel/configurator.rb:50:in
initialize' from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:innew’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in run' from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:inrun’
from
/usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
from /usr/bin/mongrel_rails:19:in `load’
from /usr/bin/mongrel_rails:19

$gem list
actionmailer (2.3.5, 2.3.3, 2.2.2)
actionpack (2.3.5, 2.3.3, 2.2.2)
activerecord (2.3.5, 2.3.3, 2.2.2)
activeresource (2.3.5, 2.3.3, 2.2.2)
activesupport (2.3.5, 2.3.3, 2.2.2)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
echoe (4.2)
fastthread (1.0.7)
gem_plugin (0.2.3)
highline (1.5.2)
json (1.2.0)
mongrel (1.1.5)
mongrel_cluster (1.0.5)
net-sftp (2.0.1)
net-ssh (2.0.6)
postgres (0.7.9.2008.01.28)
postgres-pr (0.6.3)
rack (1.1.0, 1.0.1, 1.0.0)
rails (2.3.5, 2.3.3, 2.2.2)
rake (0.8.7, 0.8.3)
rmagick (2.12.2, 2.8.0)
rubyforge (2.0.3)
sqlite3-ruby (1.2.5)

$ruby --version
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-linux]

if I try http://127.0.0.1:8000, I get an ‘unable to connect’.
I don’t know if mongrel_cluster is running ok, I think not from what the
logs says.
Is it because mongrel requires rack 1.0.0 and redmine require 1.0.1 ?
If yes, how can I fix this ?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs