Problem installing the newest version of Rails


#1

Hi,

I am just upgrading from 2.0.2 to 2.2.2 and see a lot of changes but
nothing on the release notes.

The problem I am facing right now is when I use the rake db:migrate to
create the tables, I get the following error:

rake aborted!
no such file to load – sqlite3

I have installed sqlite3 separately as it seems it is no longer
bundled with the download however, when I try to install the gem
sqlite3-ruby, I get another error:

Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

C:/Ruby/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for fdatasync() in rt.lib… no
checking for sqlite3.h… no

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

Could someone help or is this version not stable and I should revert
back to another version? I had a lot of problems with installing gems
for 2.0.2 and that is why I wanted to move to this newer version.

Any help would be appreciated

Thanks,

Frank


#2

On Dec 4, 7:07 pm, frank95a removed_email_address@domain.invalid wrote:

checking for sqlite3.h… no
So far, nothing to do with Rails :slight_smile:
You’re in windows so you need to get the version that is prebuilt for
windows. I vaguely recalled reading here that if you
gem install sqlite3-ruby --version=1.2.3

then you’ll get offered a win32 version (which you should pick)

Fred


#3

Thanks Fred, that helped a bit.

I also had to manually move sqlite3.dll and sqlite.def to the bin
directory ( I had them from a previous install)

Regards,

Frank

On Dec 4, 11:12 am, Frederick C. removed_email_address@domain.invalid