Problem installing shoes3 on RHEL 6

I am trying to install/build shoes3 under Red Hat EL 6 and I am having
heck
of a time.
I downloaded the shoes3.run.sh and when I run it I get the following
errors:

[[email protected] Downloads]# ./shoes3.run.sh
Verifying archive integrity… All good.
Uncompressing
Shoes…
/tmp/selfgz122158916/shoes-bin: error while loading shared libraries:
libssl.so.0.9.8: cannot open shared object file: No such file or
directory

So, one would think that *libssl.so.0.9.8 *is missing. I looked for it
on
the web for hours, and I can’t find it. Some sites states that this is
part
of OpenSSL. If this is the case, I already have the latest OpenSSL
installed, as you can see below.

[[email protected] Downloads]# rpm -qa | grep -i openssl
openssl-1.0.0-4.el6_0.2.x86_64
openssl098e-0.9.8e-17.el6.x86_64
openssl-1.0.0-4.el6_0.2.i686

Without exaggerations, I visited dozens of sites and browsed even more
articles about it. I CAN FIND THE DAR THING!

Any help is appreciated!

Thank you

Two things:

One: libssl.so.0.9.8 means ‘version 0.9.8,’ and you have 1.0.0
installed, so
of course there’s a mismatch. :wink:

Two: as you’ll note, it says that that won’t always work. :wink: If getting
the
older libssl installed doesn’t, then you should try building a Shoes.

Well friend, I can hardly put on a shoe. I am sure I can’t build one!

Do you happen to have a link to the instructions on how to build a shoe?

I don’t know the real reason not to uninstall the current latest version
and
install 0.9.8.

Thank you

Hm, the last person that got that error said they were using 1.8, but
you’re
obviously using 1.9.1.

Can you try running ‘gem install mechanize’ and then doing it again,
please?
If this is needed, I"ll add it to the instructions.

Actually, I did try to build my own shoes using the instructions:

git clone git://github.com/shoes/shoes.git ${SHOES_DIR}
cd ${SHOES_DIR}
sudo yum install -y giflib-devel cairo-devel libpixman-devel
pango-devel libjpeg-devel gtk2-devel libcurl-devel ruby-devel
rake

When I run this simple script, it fails with the following messages
displayed:

Initialized empty Git repository in /usr/local/shoes/.git/
remote: Counting objects: 9741, done.
remote: Compressing objects: 100% (3089/3089), done.
remote: Total 9741 (delta 6630), reused 9595 (delta 6519)
Receiving objects: 100% (9741/9741), 4.46 MiB | 41 KiB/s, done.
Resolving deltas: 100% (6630/6630), done.
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Package giflib-devel-4.1.6-3.1.el6.x86_64 already installed and latest
version
Package cairo-devel-1.8.8-3.1.el6.x86_64 already installed and latest
version
No package libpixman-devel available.
Package pango-devel-1.28.1-3.el6_0.5.x86_64 already installed and latest
version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest
version
Package gtk2-devel-2.18.9-4.el6.x86_64 already installed and latest
version
Package libcurl-devel-7.19.7-16.el6.x86_64 already installed and latest
version
Package ruby-devel-1.8.7.299-5.el6_0.1.x86_64 already installed and
latest
version
Nothing to do
(in /usr/local/shoes)
rake aborted!
no such file to load – mechanize

internal:lib/rubygems/custom_require:29:in require' <internal:lib/rubygems/custom_require>:29:inrequire’
/usr/local/shoes/Rakefile:291:in <top (required)>' /usr/local/lib/ruby/1.9.1/rake.rb:2373:inload’
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in raw_load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:2007:inblock in load_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:2058:in standard_exception_handling' /usr/local/lib/ruby/1.9.1/rake.rb:2006:inload_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:1991:in run' /usr/local/bin/rake:31:in

I think that I am missing mechanize. I tried to install at least a
dozen
times in different ways but could not.

So at this point I am totally lost!

Thank you

uname -a
Linux 2.6.32-71.24.1.el6.x86_64 #1 SMP Fri Apr 8 01:07:23 CDT 2011
x86_64 x86_64 x86_64 GNU/Linux
cat /etc/redhat-release
Scientific Linux release 6.0 (Carbon)
ruby -v
ruby 1.8.7 (2010-06-23 patchlevel 299) [x86_64-linux]

cd /tmp
git clone https://github.com/shoes/shoes.git
cd shoes
rake
rake aborted!
no such file to load – bundler
sudo gem install bundler
rake
No package ‘cairo’ found
No package ‘pango’ found
No package ‘gtk±2.0’ found
sudo yum install cairo-devel pango-devel gtk2-devel
rake
command not found: curl-config
no such file to load – mechanize
sudo yum install curl-devel
sudo gem install mechanize
rake
ERROR: Failed to build gem native extension.
sudo yum install ruby-devel
sudo gem install mechanize
libxml2 is missing.
sudo yum install libxml-devel libxslt-devel
sudo gem install mechanize
rake
error: gif_lib.h: No such file or directory
sudo yum install giflib-devel
rake
error: portaudio.h: No such file or directory
sudo yum install portaudio-devel
rake
checking for sqlite3.h… no
sudo yum install sqlite-devel
rake
No such file or directory - /usr/lib/libruby.so
sed -i ‘s;/lib/;/lib64/;g’ make/linux/tasks.rb
rake
cd dist
./shoes
no such file to load – stringio
cp /usr/lib64/ruby/1.8/stringio.so ruby/lib/
./shoes
no such file to load – rbconfig
cp /usr/lib64/ruby/1.8/rbconfig.rb ruby/lib/
./shoes
no such file to load – digest/sha1
cp -r /usr/lib64/ruby/1.8/* ruby/lib/
./shoes
“Welcome to SHOES”

unknown wrote in post #996479:

ruby -v
ruby 1.8.7 (2010-06-23 patchlevel 299) [x86_64-linux]

i think this may be your problem - i was having a similar issue, and
realized that i was trying to install shoes under 1.8.7 - which won’t
work.

if you have rvm just use a 1.9.1x version, and if necessary install
the ‘mechanize’ gem, and everything should work out alright.

  • j

Hi Steve,

Thank you for your suggestion. I already tried gen install mechanize. I
just did it again to post the outcome:

First:
[[email protected] ~]# ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]

I was missing the libxml2, as you can see from this msg:

[[email protected] ~]# gem install mechanize
Building native extensions. This could take a while…
ERROR: Error installing mechanize:
ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb
checking for libxml/parser.h… no

libxml2 is missing. please visit
http://nokogiri.org/tutorials/installing_nokogiri.html for help with
installing dependencies.

I went to the page listed above and followed the procedure listed,
installing the require packages.
I then proceded to install mechanize and it worked.

NOW I HAVE A NEW PROBLEM, WITH OPENSSL:

I tried installing openssl via: rvm package install openssl This
installation worked. However, the shoes install still complaining that
openssl is not there.
openssl
is found at:
*/usr/local/rvm/usr/bin/openssl
*:
OpenSSL> version
OpenSSL 0.9.8n 24 Mar 2010
OpenSSL>

THE FOLLOWING IS THE OUTPUT WHEN I TRY T BUILD SHOES:

Initialized empty Git repository in /usr/local/shoes/.git/
remote: Counting objects: 9741, done.
remote: Compressing objects: 100% (3089/3089), done.
remote: Total 9741 (delta 6630), reused 9595 (delta 6519)
Receiving objects: 100% (9741/9741), 4.46 MiB | 42 KiB/s, done.
Resolving deltas: 100% (6630/6630), done.
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Package giflib-devel-4.1.6-3.1.el6.x86_64 already installed and latest
version
Package cairo-devel-1.8.8-3.1.el6.x86_64 already installed and latest
version
No package libpixman-devel available.
Package pango-devel-1.28.1-3.el6_0.5.x86_64 already installed and latest
version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest
version
Package gtk2-devel-2.18.9-4.el6.x86_64 already installed and latest
version
Package libcurl-devel-7.19.7-16.el6.x86_64 already installed and latest
version
Package ruby-devel-1.8.7.299-5.el6_0.1.x86_64 already installed and
latest
version
Nothing to do
(in /usr/local/shoes)

rake aborted!
no such file to load – openssl

internal:lib/rubygems/custom_require:29:in require' <internal:lib/rubygems/custom_require>:29:inrequire’
/usr/local/lib/ruby/1.9.1/net/https.rb:92:in <top (required)>' <internal:lib/rubygems/custom_require>:29:inrequire’
internal:lib/rubygems/custom_require:29:in require' /usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in<top (required)>’
internal:lib/rubygems/custom_require:33:in require' <internal:lib/rubygems/custom_require>:33:inrescue in require’
internal:lib/rubygems/custom_require:29:in require' /usr/local/shoes/Rakefile:291:in<top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in load' /usr/local/lib/ruby/1.9.1/rake.rb:2373:inraw_load_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in block in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:2058:instandard_exception_handling’
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:1991:inrun’
/usr/local/bin/rake:31:in `’

I also checked the openssl that came with RHEL 6:
[[email protected] openssl]#* rpm -qa | grep -i openssl*
openssl-1.0.0-4.el6_0.2.x86_64
openssl098e-0.9.8e-17.el6.x86_64
openssl-1.0.0-4.el6_0.2.i686

Basically, I am totally lost.

Thank you for your help.

On Tue, May 3, 2011 at 8:33 PM, jake kaiden [email protected]
wrote:

unknown wrote in post #996479:

ruby -v
ruby 1.8.7 (2010-06-23 patchlevel 299) [x86_64-linux]

i think this may be you’re problem - i was having a similar issue, and
realized that i was trying to install shoes under 1.8.7 - which won’t
work.

Really? It built and ran:
./shoes
“Welcome to SHOES”

(I only tested one sample; I would believe that not everything would
work properly.)

if you have rvm just use a 1.9.1x version, and if necessary install
the mechanize gem, and everything should work out alright.

For the OP, yes I imagine that installing mechanize in 1.9 should get
past that hurdle. (As you can see from my transcript, I ran into
further troubles with lib64 vs lib etc.)

This means your ruby didn’t get installed with ssl support. I don’t know
how
to do that on Red Hat, as I compile my own Rubies. I know debian has
some
sort of libopenssl-ruby package that handles this, but you’ll have to
consult the docs for Red Hat. :confused:

Now I am REALLY lost!
I have the following, as I stated before:

The openssl that came with RHEL 6:
[[email protected] openssl]#* rpm -qa | grep -i openssl*
openssl-1.0.0-4.el6_0.2.x86_64
openssl098e-0.9.8e-17.el6.x86_64
openssl-1.0.0-4.el6_0.2.i686

AND

OpenSSL> version
OpenSSL 0.9.8n 24 Mar 2010
OpenSSL> q

I guess what you mean is that Ruby should have picked up openssl during
the
install. I am not sure what happened but I downloaded ruby from the
“stable”
repository and proceeded to build it.

Thank you

yes, you have openssl installed on your machine, but Ruby was not
compiled
with the bindings to it. See this google search, for example:
https://encrypted.google.com/search?hl=en&source=hp&biw=1024&bih=639&q=ruby+no+such+file+to+load+--+openssl&aq=f&aqi=&aql=&oq=

Jake,

I have Ruby 1.9.1:

[[email protected] openssl]# ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]

I also have mechanize and rvm isntalled, I just got those working:
[[email protected] openssl]# gem list

*** LOCAL GEMS ***

bundler (1.0.12)
mechanize (1.0.0)
minitest (1.6.0)
nokogiri (1.4.4)
rake (0.8.7)
rdoc (2.5.8)
rvm (1.6.5)

Thank you

On Wed, May 4, 2011 at 3:24 PM, Ruby S. [email protected]
wrote:

rake aborted!
no such file to load – openssl

I also checked the openssl that came with RHEL 6:
[[email protected] openssl]#* rpm -qa | grep -i openssl*
openssl-1.0.0-4.el6_0.2.x86_64
openssl098e-0.9.8e-17.el6.x86_64
openssl-1.0.0-4.el6_0.2.i686

Basically, I am totally lost.

rpm -qa | fgrep openssl
openssl-1.0.0-4.el6_0.2.x86_64
openssl-devel-1.0.0-4.el6_0.2.x86_64

rvm 1.9.2
ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]
irb

require ‘openssl’
=> true

directions:
rvm remove 1.9.2
sudo yum install openssl-devel
rvm install 1.9.2

Steve,

I just rebuilt ruby with openssl, using the following command:

rvm install 1.9.2 --with-openssl-dir=$HOME/.rvm/usr

This is what I got:
[[email protected] Downloads]# ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]
[[email protected] Downloads]# openssl
OpenSSL> version
OpenSSL 1.0.0-fips 29 Mar 2010
OpenSSL>

I tried building shoes in two different ways: using the shoes3.run.sh:
Verifying archive integrity… All good.
Uncompressing Shoes…
/tmp/selfgz2685625028/shoes-bin: error while loading shared libraries:
libssl.so.0.9.8: cannot open shared object file: No such file or
directory

AND USING THE FOLLOWING:

git clone git://github.com/shoes/shoes.git ${SHOES_DIR}
cd ${SHOES_DIR}
sudo yum install -y giflib-devel cairo-devel libpixman-devel pango-devel
libjpeg-devel gtk2-devel libcurl-devel ruby-devel
rake

fatal: destination path ‘/usr/local/shoes’ already exists and is not an
empty directory.
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Package giflib-devel-4.1.6-3.1.el6.x86_64 already installed and latest
version
Package cairo-devel-1.8.8-3.1.el6.x86_64 already installed and latest
version
No package libpixman-devel available.
Package pango-devel-1.28.1-3.el6_0.5.x86_64 already installed and latest
version
Package libjpeg-devel-6b-46.el6.x86_64 already installed and latest
version
Package gtk2-devel-2.18.9-4.el6.x86_64 already installed and latest
version
Package libcurl-devel-7.19.7-16.el6.x86_64 already installed and latest
version
Package ruby-devel-1.8.7.299-5.el6_0.1.x86_64 already installed and
latest
version
Nothing to do
(in /usr/local/shoes)
rake aborted!
no such file to load – openssl
internal:lib/rubygems/custom_require:29:in require' <internal:lib/rubygems/custom_require>:29:inrequire’
/usr/local/lib/ruby/1.9.1/net/https.rb:92:in <top (required)>' <internal:lib/rubygems/custom_require>:29:inrequire’
internal:lib/rubygems/custom_require:29:in require' /usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in<top (required)>’
internal:lib/rubygems/custom_require:33:in require' <internal:lib/rubygems/custom_require>:33:inrescue in require’
internal:lib/rubygems/custom_require:29:in require' /usr/local/shoes/Rakefile:291:in<top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in load' /usr/local/lib/ruby/1.9.1/rake.rb:2373:inraw_load_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in block in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:2058:instandard_exception_handling’
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:1991:inrun’
/usr/local/bin/rake:31:in `’

IT FAILED BOTH WAYS.

HELP PLEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEASE!

Thank you

Brabuhr,

OK, this is the outcome of the suggested sequence:
[[email protected] Downloads]# rvm remove 1.9.2
Removing /usr/local/rvm/src/ruby-1.9.2-p180…
Removing /usr/local/rvm/rubies/ruby-1.9.2-p180…
Removing ruby-1.9.2-p180 aliases…
Removing ruby-1.9.2-p180 wrappers…
Removing ruby-1.9.2-p180 environments…
Removing ruby-1.9.2-p180 binaries…
[[email protected] Downloads]# ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]
[[email protected] Downloads]# sudo yum install openssl-devel
Loaded plugins: ibm-cds-plugin, ibm-repository, refresh-packagekit
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package openssl-devel.x86_64 0:1.0.0-4.el6_0.2 set to be updated
–> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================
Package Arch
Version Repository
Size

Installing:
openssl-devel x86_64
1.0.0-4.el6_0.2 RHEL-6-Updates-x86_64
1.1 M

Transaction Summary

Install 1 Package(s)
Upgrade 0 Package(s)

Total download size: 1.1 M
Installed size: 2.1 M
Is this ok [y/N]: y
Downloading Packages:
openssl-devel-1.0.0-4.el6_0.2.x86_64.rpm
| 1.1 MB 00:57
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing :
openssl-devel-1.0.0-4.el6_0.2.x86_64
1/1

Installed:
openssl-devel.x86_64
0:1.0.0-4.el6_0.2

Complete!

On Wed, May 4, 2011 at 12:18 PM, [email protected] wrote:

require ‘openssl’
=> true

directions:
rvm remove 1.9.2
sudo yum install openssl-devel
rvm install 1.9.2

The results was the same:

rake aborted!
no such file to load – openssl

internal:lib/rubygems/custom_require:29:in require' <internal:lib/rubygems/custom_require>:29:inrequire’
/usr/local/lib/ruby/1.9.1/net/https.rb:92:in <top (required)>' <internal:lib/rubygems/custom_require>:29:inrequire’
internal:lib/rubygems/custom_require:29:in require' /usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in<top (required)>’
internal:lib/rubygems/custom_require:33:in require' <internal:lib/rubygems/custom_require>:33:inrescue in require’
internal:lib/rubygems/custom_require:29:in require' /usr/local/shoes/Rakefile:291:in<top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:2373:in load' /usr/local/lib/ruby/1.9.1/rake.rb:2373:inraw_load_rakefile’
/usr/local/lib/ruby/1.9.1/rake.rb:2007:in block in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:2058:instandard_exception_handling’
/usr/local/lib/ruby/1.9.1/rake.rb:2006:in load_rakefile' /usr/local/lib/ruby/1.9.1/rake.rb:1991:inrun’
/usr/local/bin/rake:31:in `’

Thank you

Well gents,

After 10 hours of playing with this, I thought I got it.
I passed the mechanize, the libxml2, the openssl, the /osama/bin/laden,
etc.
And just when I thought T had it, I got the following.
Please notice that I am only copying a small segment (the end) of the
output, which I think is the relevant part:

rm -f dist/shoes
rm -f dist/shoes-bin
gcc -Ldist -o dist/shoes-bin bin/main.o -lruby -lcairo -lpangocairo-1.0
-lungif -ljpeg -lrt -L/usr/local/lib -lcairo -lpango-1.0 -lgobject-2.0
-lgmodule-2.0 -lglib-2.0 -lshoes -L. -rdynamic -Wl,-export-dynamic
bin/main.o: In function main': main.c:(.text+0x64): undefined reference toruby_snprintf’
main.c:(.text+0xa7): undefined reference to ruby_run_node' dist/libshoes.so: undefined reference toruby_vsnprintf’
dist/libshoes.so: undefined reference to rb_str_new_cstr' dist/libshoes.so: undefined reference torb_intern2’
collect2: ld returned 1 exit status
rake aborted!
Command failed with status (1): [gcc -Ldist -o dist/shoes-bin bin/main.o
-l…]
/usr/local/lib/ruby/1.9.1/rake.rb:993:in block in sh' /usr/local/lib/ruby/1.9.1/rake.rb:1008:incall’
/usr/local/lib/ruby/1.9.1/rake.rb:1008:in sh' /usr/local/lib/ruby/1.9.1/rake.rb:1092:insh’
/usr/local/shoes/make/linux/tasks.rb:45:in make_app' /usr/local/shoes/Rakefile:113:inblock in <top (required)>’
/usr/local/lib/ruby/1.9.1/rake.rb:632:in call' /usr/local/lib/ruby/1.9.1/rake.rb:632:inblock in execute’
/usr/local/lib/ruby/1.9.1/rake.rb:629:in each' /usr/local/lib/ruby/1.9.1/rake.rb:629:inexecute’
/usr/local/lib/ruby/1.9.1/rake.rb:595:in block in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/monitor.rb:201:inmon_synchronize’
/usr/local/lib/ruby/1.9.1/rake.rb:588:in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/rake.rb:605:inblock in invoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:602:in each' /usr/local/lib/ruby/1.9.1/rake.rb:602:ininvoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:594:in block in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/monitor.rb:201:inmon_synchronize’
/usr/local/lib/ruby/1.9.1/rake.rb:588:in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/rake.rb:605:inblock in invoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:602:in each' /usr/local/lib/ruby/1.9.1/rake.rb:602:ininvoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:594:in block in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/monitor.rb:201:inmon_synchronize’
/usr/local/lib/ruby/1.9.1/rake.rb:588:in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/rake.rb:605:inblock in invoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:602:in each' /usr/local/lib/ruby/1.9.1/rake.rb:602:ininvoke_prerequisites’
/usr/local/lib/ruby/1.9.1/rake.rb:594:in block in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/monitor.rb:201:inmon_synchronize’
/usr/local/lib/ruby/1.9.1/rake.rb:588:in invoke_with_call_chain' /usr/local/lib/ruby/1.9.1/rake.rb:581:ininvoke’
/usr/local/lib/ruby/1.9.1/rake.rb:2041:in invoke_task' /usr/local/lib/ruby/1.9.1/rake.rb:2019:inblock (2 levels) in
top_level’
/usr/local/lib/ruby/1.9.1/rake.rb:2019:in each' /usr/local/lib/ruby/1.9.1/rake.rb:2019:inblock in top_level’
/usr/local/lib/ruby/1.9.1/rake.rb:2058:in standard_exception_handling' /usr/local/lib/ruby/1.9.1/rake.rb:2013:intop_level’
/usr/local/lib/ruby/1.9.1/rake.rb:1992:in run' /usr/local/bin/rake:31:in

Thank you

Doing a quick test under rvm 1.9.2…

You have to then reinstall 1.9.2 after installing openssl-devel for it
to
build a ruby with it. :wink:
Also,
/usr/local/lib/ruby/gems/1.9.1/gems/mechanize-1.0.0/lib/mechanize.rb:2:in
`<top (required)>’ suggests that you’re still using your system Ruby,
rather
than the rvm one, as it’s usuall ~/.rvm/…

Excellent. I’m sorry this was so much stress, making the build process
better is something I’m taking a hard look at currently.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs