Problem installing rubygems on Ruby 1.9 RC

OK, so with help from Reacher and Luis, I was able to run my hello
world program with Ruby 1.9.

(Had to turn of RUBYOPT env variable)

Now I tried installing Rubygems (rubygems-0.9.5) using setup.rb
provided and got following error.

{{{
Removing old RubyGems RDoc and ri…
rm -rf d:/ruby19/lib/ruby/gems/1.9/doc/rubygems-0.9.5
Installing rubygems-0.9.5 ri into d:/ruby19/lib/ruby/gems/1.9/doc/
rubygems-0.9.5
/ri…

RDoc failure in lib/rubygems/source_index.rb at or around line 325
column 18

Before reporting this, could you check that the file
you’re documenting compiles cleanly–RDoc is not a
full Ruby parser, and gets confused easily if fed
invalid programs.

The internal error was:

d:/ruby19/lib/ruby/1.9/e2mmap.rb:161:in Raise': $! not set (ArgumentError) from d:/ruby19/lib/ruby/1.9/e2mmap.rb:93:infail’
from d:/ruby19/lib/ruby/1.9/rdoc/parsers/parse_rb.rb:1130:in
identify_q uotation' from d:/ruby19/lib/ruby/1.9/rdoc/parsers/parse_rb.rb:909:inblock in le
x_int2’
}}}

However, I could compile d:/ruby19/lib/ruby/1.9/e2mmap.rb
{{{
D:\ruby19\lib\ruby\1.9>ruby -c e2mmap.rb
Syntax OK
}}}

Any suggestions?

regards,
Ashutosh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs