Problem installing rubygems on Mac OS X 10.5.6


#1

I just recently started getting back into Rails now that the new Agile
Web
Development with Rails book (3rd edition) came out.

I had an old, out-of-date installation of ruby and gem so I tried to
follow
the advice found at:

http://blog.carlmercier.com/2007/12/14/how-to-fix-that-rubygems-mess-on-leopard/

which recommended completely removing the Apple installed ruby and gem.
After doing so, I then installed using MacPort per the instructions.
Installation went okay until attempting to update Rubygems per this
command:

sudo gem update --system

This resulted in an error:

/opt/local/bin/gem:14: undefined method `ruby_version’ for Gem:Module
(NoMethodError)

I googled for a solution and found this solution:

http://cristian.livadaru.net/2008/07/22/how-to-solve-undefined-method-ruby_version-for-gemmodule-nomethoderror-on-os-x/

However after trying that solution I got yet another error:

gem install -l rubygems-update-1.2.0.gem

/opt/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:18:in
initialize': uninitialized constant Gem::CommandManager (NameError) from /opt/local/bin/gem:24:innew’
from /opt/local/bin/gem:24

So I am wondering: Why is it so (apparently) difficult to update ruby
and
gem on Mac OS X? Is it just me? Or others having this same problem? This
struggle to get ruby and gem up to date seems antithetical to the ease
with
which rails in general seems to work. This kind of makes me wish for an
‘Instant Rails’ solution for Mac OS X!

Does anyone here have an up-to-date solution for installing ruby 1.8.7
and
gem 1.3.1 from scratch on Mac OS X that works?

TIA!


View this message in context:
http://www.nabble.com/Problem-installing-rubygems-on-Mac-OS-X-10.5.6-tp22772141p22772141.html
Sent from the RubyOnRails Users mailing list archive at Nabble.com.


#2

stug23 wrote:
[…]

I had an old, out-of-date installation of ruby and gem so I tried to
follow
the advice found at:

http://blog.carlmercier.com/2007/12/14/how-to-fix-that-rubygems-mess-on-leopard/

which recommended completely removing the Apple installed ruby and gem.

That link didn’t work, but I can’t for the life of me see why you’d need
to do that anyway. I’ve had no problems with the Apple-supplied Ruby on
Leopard. (Things were different on Tiger.)

This kind of makes me wish for an
‘Instant Rails’ solution for Mac OS X!

You shouldn’t need it on Leopard, but try Locomotive. It was designed
for Tiger, but I believe it still works.

Does anyone here have an up-to-date solution for installing ruby 1.8.7
and
gem 1.3.1 from scratch on Mac OS X that works?

Yes. Just use Apple’s versions and upgrade as necessary. :slight_smile:

TIA!

Best,

Marnen Laibow-Koser
removed_email_address@domain.invalid
http://www.marnen.org


#3

You didn’t need to uninstall Apple’s ruby and gems. Simply install your
own in a separate folder and then edit your PATH variable to tell the
system where to look for. What’s the output of $ ruby -v ? is it as
expected?