Problem installing rubygems-0.8.11

I’m having an issue installing rubygems-0.8.11 on 2 different boxes
but get the same error on both. The first box is a host environment
where I am cross-compiling things for the arm-linux architecture. It
is a debian sarge box using the ruby1.8 package which is ruby-1.8.2.
I successfully cross-compiled ruby 1.8.4 for the arm-linux
architecture and it runs well on the embedded linux box.

On both boxes, when I run “ruby setup.rb” I get the following output
and error at the bottom which is identical on both boxes:

sudo ruby setup.rb
Password:
—> bin
<— bin
—> lib
—> lib/rubygems
<— lib/rubygems
<— lib
—> bin
<— bin
—> lib
—> lib/rubygems
<— lib/rubygems
<— lib
rm -f InstalledFiles
—> bin
mkdir -p /usr/bin/
install gem /usr/bin/
install generate_yaml_index.rb /usr/bin/
install gem_mirror /usr/bin/
install gem_server /usr/bin/
install gemwhich /usr/bin/
install update_rubygems /usr/bin/
<— bin
—> lib
mkdir -p /usr/local/lib/site_ruby/1.8/
install ubygems.rb /usr/local/lib/site_ruby/1.8/
install rubygems.rb /usr/local/lib/site_ruby/1.8/
install gemconfigure.rb /usr/local/lib/site_ruby/1.8/
—> lib/rubygems
mkdir -p /usr/local/lib/site_ruby/1.8/rubygems
install config_file.rb /usr/local/lib/site_ruby/1.8/rubygems
install gem_openssl.rb /usr/local/lib/site_ruby/1.8/rubygems
install user_interaction.rb /usr/local/lib/site_ruby/1.8/rubygems
install source_index.rb /usr/local/lib/site_ruby/1.8/rubygems
install cmd_manager.rb /usr/local/lib/site_ruby/1.8/rubygems
install deployment.rb /usr/local/lib/site_ruby/1.8/rubygems
install gem_runner.rb /usr/local/lib/site_ruby/1.8/rubygems
install gem_commands.rb /usr/local/lib/site_ruby/1.8/rubygems
install doc_manager.rb /usr/local/lib/site_ruby/1.8/rubygems
install installer.rb /usr/local/lib/site_ruby/1.8/rubygems
install remote_installer.rb /usr/local/lib/site_ruby/1.8/rubygems
install old_format.rb /usr/local/lib/site_ruby/1.8/rubygems
install builder.rb /usr/local/lib/site_ruby/1.8/rubygems
install rubygems_version.rb /usr/local/lib/site_ruby/1.8/rubygems
install format.rb /usr/local/lib/site_ruby/1.8/rubygems
install custom_require.rb /usr/local/lib/site_ruby/1.8/rubygems
install specification.rb /usr/local/lib/site_ruby/1.8/rubygems
install dependency_list.rb /usr/local/lib/site_ruby/1.8/rubygems
install command.rb /usr/local/lib/site_ruby/1.8/rubygems
install package.rb /usr/local/lib/site_ruby/1.8/rubygems
install timer.rb /usr/local/lib/site_ruby/1.8/rubygems
install loadpath_manager.rb /usr/local/lib/site_ruby/1.8/rubygems
install validator.rb /usr/local/lib/site_ruby/1.8/rubygems
install open-uri.rb /usr/local/lib/site_ruby/1.8/rubygems
install version.rb /usr/local/lib/site_ruby/1.8/rubygems
install security.rb /usr/local/lib/site_ruby/1.8/rubygems
<— lib/rubygems
<— lib

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
while)…
…done.
No library stubs found.

hook /home/jhodapp/temp/rubygems-0.8.11/./post-install.rb failed:
uninitialized constant YAML::Syck::Resolver
Try ‘ruby setup.rb --help’ for detailed usage.

I have Syck installed…
/usr/lib/ruby/1.8/i386-linux/syck.so
/usr/lib/ruby/1.8/yaml/syck.rb

I am not sure why I am getting this error and would like to resolve
it if possible.

Thanks,

Jim Hodapp

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs