Problem install rmagick


#1

gem1.8 install rmagick works fine, but:

gem1.9 install rmagick

Building native extensions. This could take a while…
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.9 extconf.rb install rmagick
extconf.rb:1:in require': no such file to load -- mkmf (LoadError) from extconf.rb:1:in

Gem files will remain installed in
/var/lib/gems/1.9.0/gems/rmagick-2.9.1 for inspection.
Results logged to
/var/lib/gems/1.9.0/gems/rmagick-2.9.1/ext/RMagick/gem_make.out


#2

Fresh M. wrote:

Gem files will remain installed in
/var/lib/gems/1.9.0/gems/rmagick-2.9.1 for inspection.
Results logged to
/var/lib/gems/1.9.0/gems/rmagick-2.9.1/ext/RMagick/gem_make.out

mkmf.rb is part of the standard library in Ruby. Either you don’t have
it installed or it’s not in Ruby’s library path. How did you install
Ruby 1.9?