Problem in loading files (require...)

Hello
I’ve installed VimMate, but when I run it I’ve the following error :
‘Module gtk2 is required to run this program’
But when I verify, I’ve a folder gtk2, gtk2.rb and gnome2.rb in
/usr/lib/ruby/site_ruby/1.8/

And I’ve the same problem with require ‘SVG’, I installed this gem from
a .gem file and I see it in :
/usr/local/lib/ruby/site_ruby/1.8/
But I can’t use it and it’s not listed in the output of the command ‘gem
list’

Thanks

On Dec 25, 10:23 am, “Abir B.” [email protected] wrote:

Hello
I’ve installed VimMate, but when I run it I’ve the following error :
‘Module gtk2 is required to run this program’
But when I verify, I’ve a folder gtk2, gtk2.rb and gnome2.rb in
/usr/lib/ruby/site_ruby/1.8/

And I’ve the same problem with require ‘SVG’, I installed this gem from
a .gem file and I see it in :
/usr/local/lib/ruby/site_ruby/1.8/

Did you use “gem install …” to install it?
Looks like your have ruby installed in both /usr and /usr/local, which
may surely lead to confusion.

Vasyl S. wrote:

On Dec 25, 10:23 am, “Abir B.” [email protected] wrote:

Hello
I’ve installed VimMate, but when I run it I’ve the following error :
‘Module gtk2 is required to run this program’
But when I verify, I’ve a folder gtk2, gtk2.rb and gnome2.rb in
/usr/lib/ruby/site_ruby/1.8/

And I’ve the same problem with require ‘SVG’, I installed this gem from
a .gem file and I see it in :
/usr/local/lib/ruby/site_ruby/1.8/

Did you use “gem install …” to install it?
Looks like your have ruby installed in both /usr and /usr/local, which
may surely lead to confusion.

Yes I think I have confusion between Ruby versions because I uninstalled
Ruby from Linux by yum, but I still have it… And this two folders
still exists

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs