Problem in Installing facebook_oauth GEM in Windows

Hi ,

I am using ruby 1.8.6 and rails 2.3.5 in windows…

I have to install facebook_oauth gem, but i got below the error:

C:\Documents and Settings\Administrator>gem install facebook_oauth
-v=0.3.0
Temporarily enhancing PATH to include DevKit…
Building native extensions. This could take a while…
ERROR: Error installing facebook_oauth:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb
creating Makefile

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/json-1.6.4 for
inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/json-1.6.4/ext/json/ext/parser/
gem_make.out

C:\Documents and Settings\Administrator>

Kindly some one know the issues reply me…

Thanks,
B.Sundhari

Sundhari Bala wrote in post #1039004:

Hi ,

I am using ruby 1.8.6 and rails 2.3.5 in windows…

I have to install facebook_oauth gem, but i got below the error:

C:\Documents and Settings\Administrator>gem install facebook_oauth
-v=0.3.0
Temporarily enhancing PATH to include DevKit…
Building native extensions. This could take a while…
ERROR: Error installing facebook_oauth:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb
creating Makefile

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

You’ve installed RubyInstaller DevKit (MinGW+MSYS) while the version of
Ruby you have installed is looking for Visual Studio instead.

So: you’re mixing a version of Ruby with the wrong compiler and by that,
is not working.

Dunno where you obtained that version of Ruby (or how old is it) but you
have two options:

A) Get Visual Studio for that version of Ruby

If is ‘i386-mswin32’ then you need Visual Studio 6.0, which is highly
unlikely available free and online

B) Use RubyInstaller + RubyInstaller’s DevKit instead

Removing that version of Ruby and use RubyInstaller, which is compiled
with GCC and the DevKit is freely available.

All the information about RubyInstaller and the DevKit is available in
the website where you obtained the DevKit.

I recommend you use latest Ruby 1.8.7 and DevKit 4.5.2

Good luck,

Luis L.

Hi Luis,

I am using Ruby 1.8.6 , gem 1.3.5 , rails 2.3.5 and Devkit 4.5.1

Again i am getting this problem…

Kindly help me.

C:\Documents and Settings\Administrator>gem install facebook_oauth
-v=0.3.0
Temporarily enhancing PATH to include DevKit…
Building native extensions. This could take a while…
ERROR: Error installing facebook_oauth:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb
creating Makefile

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/json-1.6.4 for
inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/json-1.6.4/ext/json/ext/parser/
gem_make.out

C:\Documents and Settings\Administrator>

Thanks,
B.Sundhari

Sundhari Bala wrote in post #1039108:

Hi Luis,

I am using Ruby 1.8.6 , gem 1.3.5 , rails 2.3.5 and Devkit 4.5.1

Again i am getting this problem…

Kindly help me.

C:\Documents and Settings\Administrator>gem install facebook_oauth
-v=0.3.0
Temporarily enhancing PATH to include DevKit…
Building native extensions. This could take a while…
ERROR: Error installing facebook_oauth:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb
creating Makefile

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

Seems you didn’t read my response.

The version of Ruby you’re using (which is platform i386-mswin32) is
expecting you have Visual Studio installed.

What you installed using RubyInstaller DevKit was GCC, which is not
compatible with the version of the Ruby you have installed.

You need to use a version of Ruby provided by RubyInstaller and the
DevKit.

The DevKit only works with GCC-compiled Ruby, not Visual Studio one.

So, if you execute this:

ruby -v

And see “i386-mswin32”, DevKit will not work with that version of Ruby,
period. There is nothing I can do to help you beyond what I’ve stated
before: get RubyInstaller.

I can’t help you further if you still have problems understanding what
I’ve stated above.


Luis L.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs