Problem in gnuradio-core build


#1

Something was recently changed in the gnuradio-core make that causes an
error:

Notice the waiting for jobs. This was compiled with make, not buildit.
I was having a problem with doing the build on darwin, MacOSX and then I
ran into the same problem at Frank B.'s.

By the way, the build on Darwin, once I had all of the preliminaries
installed went beautifully. I could do

./for-add-dirs …/buildit

and have it succeed.

I will say more on Friday after I finish some usrp testing on it. If
anyone has a clue about the stuff below, let me know. The build
actually finishes and make check works after you run make a second
time. I am wondering if this has anything to do with the modifications
made to have the tar balls come out just right. Notice the swig’d file
that can’t be found. The second make succeeds.

Bob

then if test linux-gnu = mingw32;
then sed ‘s,\\,/,g’ <gnuradio_swig_python.Td

gnuradio_swig_python.d; rm -f gnuradio_swig_python.Td;
else mv -f gnuradio_swig_python.Td gnuradio_swig_python.d; fi
else rm -f gnuradio_swig_python.Td; exit 1; fi
./gen-swig-bug-fix gnuradio_swig_python.cc
gnuradio_swig_bug_workaround.h
Traceback (most recent call last):
File “./gen-swig-bug-fix”, line 110, in ?
main ()
File “./gen-swig-bug-fix”, line 107, in main
doit (input, output)
File “./gen-swig-bug-fix”, line 88, in doit
del words[w]
KeyError: ‘’
make[4]: *** [gnuradio_swig_bug_workaround.h] Error 1
make[4]: *** Waiting for unfinished jobs…
mv: cannot stat gnuradio_swig_python.Td': No such file or directory make[4]: *** [gnuradio_swig_python.h] Error 1 make[4]: Leaving directory/home/n4hy/gr-build/gnuradio-core/src/lib/swig’
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory /home/n4hy/gr-build/gnuradio-core/src/lib' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory/home/n4hy/gr-build/gnuradio-core/src’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/n4hy/gr-build/gnuradio-core’
make: *** [all] Error 2


#2

On Wed, Apr 12, 2006 at 08:09:54PM -0400, Robert McGwier wrote:

./for-add-dirs …/buildit
Bob
I’m back from traveling and will be sorting out the tarball build
problems as soon as I get out from under this email avalanche.

I don’t think anything has changed in gnuradio-core (at least by me)
for a while.

Were you using “make -j N” by any chance? That might account for
the “waiting for unfinished jobs” part. FWIW, I haven’t tested with
N > 1, so YMMV.


#3

Eric B. wrote:

installed went beautifully. I could do
that can’t be found. The second make succeeds.
Were you using “make -j N” by any chance? That might account for
the “waiting for unfinished jobs” part. FWIW, I haven’t tested with
N > 1, so YMMV.

Welcome back. Glad you made it home safely. When I saw the “waiting
for jobs” I became concerned that buildit might be doing make -j N with
N>1. So I cleaned up and did

bootstrap;./configure;make -j 1

just as a forcing thing and the error messages you see were a result.

Its pretty neat about lastest Python (2.4.3), wxPython (latest release)
and Numeric(24-2) along with swig-1.3.29 and latest portaudio causing

./for-all-dirs …/buildit

to “just work” on Darwin.

I am pretty excited for the cross platform development of all sorts of
things if something as complex as gnuradio will build and run with
headaches on Linux and Darwin. I suspect that MinGW will get us there
eventually on Windows as well.

Bob


AMSAT VP Engineering. Member: ARRL, AMSAT-DL, TAPR, Packrats,
NJQRP/AMQRP, QRP ARCI, QCWA, FRC. ARRL SDR Wrk Grp Chairman
Laziness is the number one inspiration for ingenuity. Guilty as
charged!